Skip to content

Commit

Permalink
app-shells/mksh: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
X-SoB-Autogenerated: yes
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Mar 14, 2019
1 parent c63e01c commit 5bc9d8f
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/mksh/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mksh-R56c.tgz 417218 BLAKE2B 3512855dd177be8432fe503716ca571a3c06ab3eeb6b44de923ab7d9eb9246087f627b7d7a3e9bb29a849da126b88c223864f140b136e922776ec7bd4a04e96d SHA512 7e4cd2d24c6bca2ebad7c6b02d158188e766bd4693d93f5bed198d69238aef078d42ce911431ad4e419e4af55083047d823bfad53973db5c6d8a685482770135
DIST mksh-R57.tgz 419604 BLAKE2B 11af09535ace3fdd982189fb7d7f3e5961776c3bdbf6b981f4f1506a66ebdbd893efb9aa50a5a36fd8b3b7bd3e149021aad154888dc81e0de29f41e91eeb583c SHA512 7d7fa557c17da4f1f62f82877a136439efb6d4f9fde52b2df39214db09868982e756df6e4fe83498f9013cbcf3252dc383b00ddfafaa4c9f143ffded7cd255b3
47 changes: 47 additions & 0 deletions app-shells/mksh/mksh-57.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils toolchain-funcs

DESCRIPTION="MirBSD KSH Shell"
HOMEPAGE="http://mirbsd.de/mksh"
SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="static"
DEPEND="static? ( dev-libs/klibc )"
RDEPEND=""
S="${WORKDIR}/${PN}"

src_compile() {
tc-export CC
# we want to build static with klibc
if use static ; then
unset CC
export CC="/usr/bin/klcc"
export LDSTATIC="-static"
fi
export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
sh Build.sh -r || die
}

src_install() {
exeinto /bin
doexe mksh
doman mksh.1
dodoc dot.mkshrc
}

src_test() {
./test.sh || die
}

pkg_postinst() {
ebegin "Updating /etc/shells"
( grep -v "^/bin/mksh$" "${ROOT}"etc/shells; echo "/bin/mksh" ) > "${T}"/shells
mv -f "${T}"/shells "${ROOT}"etc/shells
eend $?
}

0 comments on commit 5bc9d8f

Please sign in to comment.