Skip to content

Commit

Permalink
dev-util/drone: Version bump to 0.6.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
mrueg committed May 12, 2017
1 parent 8c95d4e commit 5c3185e
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/drone/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST drone-0.6.0.tar.gz 4144602 SHA256 afcaa71b996f7607240f0b3a1b61fd0d22a662d1d470275cc753a325314765fd SHA512 e399efabca00f8109944e51f69f21e070e9190c77b1be169b93698e19a483d6811ebba4214e22ee1dde161a47f197c83f5380a75308bbbe9b0d2c20ec569a904 WHIRLPOOL c86f89226c764537f1fe2921b63bbdfcce257c206b16e3dcca581f47798290c5b9f3f9e60467fd9326e76dd7198394f015abf4869af03efd6258984863188bdb
DIST drone-0.6.0_rc2_p20160509.tar.gz 4203293 SHA256 12e6446ec31bd8bd9877c4f6062397cc355e73099b80a765f987f951b875a33e SHA512 3e06decf801e746783183e0866d1b24beac7af890fba6e41cfbe780cb7db06adcfb0c7723946e1339b49bb433ed8587f6e9841b8bc2f54c305530f5254b2575c WHIRLPOOL a0be6edbc96a26ba0d114037d9e10d0adb1e532d7518c970e8ac55f23d5aa3686414a97678395b4bc56e19ed2369b76f4e38b924620865613cba9cf5b24daa80
DIST drone-0.6.0_rc2_p20170512.tar.gz 4144606 SHA256 e38477f828e879aa81b51dbc3358bb1dfa800e19947755e82717e48591bb897f SHA512 440576a347a7225e0ec1e874eb4c77a073688e2230f629882b646118c17c83dcaa62afa1d0faad5f27708943edee43849c9c96e6e81279623ca9da5e2908323b WHIRLPOOL 5ac8f42e1af920c86196d79acee5a92a98e1de242e79da409f40463ec84beae0a3e278c1cce9ec7e62dae06901c9140edebceee7d3c06120d8ce865ca1e37d6a
DIST github.com-drone-drone-ui-72dc649bc4ff81f4560ab70b29495830a4c1cf3d.tar.gz 167100 SHA256 9e80fff7012b0f54fea80d4725e415c3fc0ced496692baa28bde7e5908b9b314 SHA512 4225d7372e4598dc9aa2eb0e645b3df3f71f7ca7f591d9a198da95276cd47fa2bf7acc808cc4a15ca80f33b259e43e0771744c98f3ff8d016919f1b7d15520b7 WHIRLPOOL 13e4cd0672d9f145c6dc6d5d6cc3f1bd532c02fbb6d8c94ecfb39e50f2471d4b0b5b030aa99bb7f105608225b183dd51a2f5666ddd2b96bcf9ef1c232d16ab4d
Expand Down
48 changes: 48 additions & 0 deletions dev-util/drone/drone-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="github.com/drone/drone/..."
EGIT_COMMIT="823175605f61ddf18b8566e04f6e94d550762d99"
EGO_VENDOR=( "github.com/drone/drone-ui 72dc649bc4ff81f4560ab70b29495830a4c1cf3d" )

inherit golang-build golang-vcs-snapshot user

ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="A Continuous Delivery platform built on Docker, written in Go"
HOMEPAGE="https://github.com/drone/drone"
SRC_URI="${ARCHIVE_URI}
${EGO_VENDOR_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="dev-go/go-bindata
dev-go/go-bindata-assetfs:="

pkg_setup() {
enewgroup drone
enewuser drone -1 -1 /var/lib/drone drone
}

src_compile() {
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/github.com/drone/drone gen || die
pushd src || die
DRONE_BUILD_NUMBER="${EGIT_COMMIT:0:7}" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)"\
go install -ldflags "-extldflags '-static' -X github.com/drone/drone/version.VersionDev=build.${EGIT_COMMIT:0:7}" github.com/drone/drone/drone || die
popd || die
}

src_install() {
dobin bin/*
dodoc src/github.com/drone/drone/README.md
keepdir /var/log/drone /var/lib/drone
fowners -R drone:drone /var/log/drone /var/lib/drone
newinitd "${FILESDIR}"/drone.initd drone
newconfd "${FILESDIR}"/drone.confd drone
newinitd "${FILESDIR}"/drone-agent.initd drone-agent
newconfd "${FILESDIR}"/drone-agent.confd drone-agent
}

0 comments on commit 5c3185e

Please sign in to comment.