forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/zope-testrunner: version bump to 4.7.0
- Loading branch information
Showing
2 changed files
with
45 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST zope.testrunner-4.6.0.zip 278215 SHA256 f57aa4729c353a137090081ad110d6bdf3a6489108e6878136e907fc14d6edff SHA512 4f90f7111f36cfca95b062cacc947a6f547871e5fb182e56190009217c517566199e79c768fa4a451c945c8916ed596f54b4ff06552bde3a160a7a7e03b22ff5 WHIRLPOOL 26c00298bbbc106d3e0f82a3d6bee382b987f634ef45a532548ef795ec942a2de59526572ad7f66b04dd67ad2044cc6ee9682e350e0870a4954edeed07ce69dc | ||
DIST zope.testrunner-4.7.0.zip 260508 SHA256 8ffcb4989829544a83d27e42b2eeb28f8fc134bd847d71ce8dca54f710526ef0 SHA512 edda96e6871d954bb1f46ca18e2de9d1726d68cb3787f080b3b858c4dbdc2ceeb809962d178350a354e16c04711a89b2c6d1f663f256e1f72c15a7c494e51d32 WHIRLPOOL b1701ef2b103c79a33b8b5a62b34d46a70bee47c7fb408676e89354d0fbb464d081f6c31cf27fea0d41371c9cfb6208fe0ba875d47037f0a9b5d747940fe5d6b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} ) | ||
inherit distutils-r1 | ||
|
||
MY_PN=${PN/-/.} | ||
MY_P=${MY_PN}-${PV} | ||
|
||
DESCRIPTION="Zope testrunner script" | ||
HOMEPAGE="https://pypi.python.org/pypi/zope.testrunner https://github.com/zopefoundation/zope.testrunner" | ||
SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.zip" | ||
|
||
LICENSE="ZPL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
# TODO: extras? | ||
RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}] | ||
dev-python/six[${PYTHON_USEDEP}] | ||
dev-python/zope-exceptions[${PYTHON_USEDEP}] | ||
dev-python/zope-interface[${PYTHON_USEDEP}]" | ||
DEPEND="${RDEPEND} | ||
app-arch/unzip | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
python_test() { | ||
# some tests rely on .pyc files being present | ||
local -x PYTHONDONTWRITEBYTECODE= | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
# remove .pth files since dev-python/namespace-zope handles the ns | ||
find "${D}" -name '*.pth' -delete || die | ||
} |