Skip to content

Commit

Permalink
dev-lang/qu-prolog: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Keri Harris <[email protected]>
  • Loading branch information
keriharris committed Jun 25, 2020
1 parent 82c423c commit 5c4d7da
Show file tree
Hide file tree
Showing 3 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/qu-prolog/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST qp10.1.tar.gz 1521610 BLAKE2B a4d6d277a35284accfff1afd70901218df198b2b33f5c
DIST qp10.2.tar.gz 1667066 BLAKE2B fe466bc892a0923f463347bfa22618061d8a8baf9e2fc60ea27694c66be6dc8ac9b0bacd3084bccff95ff06ef949660cb9a0637a8e3e3595d04c44eb2b682bc9 SHA512 5cfebab17a812513bb4ddf4c04890af32339bef18d746dd6503cee13d295c43f1ef687a6c7814b2f40473766c695459f8234541ae8a6945a0f2930556985ad96
DIST qp10.3.tar.gz 1669345 BLAKE2B 9dc14f683555b22e7bb2119dd6d29cad7c934bb162def4358d69da65cd259b586fac593c7770dc1d665ab56da2e1129a696e84b01a271b747a9e3a8598c0d7fa SHA512 e28519fccf58f2b755382f2b8e56c15f2622508822c920975577feb6b837f96346a14eb23a5209ed126e617264ed7846b8a35d5936e99284503d5c435c0a1c18
DIST qp10.4.tar.gz 1671144 BLAKE2B 293cbc09a058714f762e5d371074ca1b87e8177868851a3db2606a837810b474e926c43f6715c5088c718f2b1841c46f9668795ac53edc0266a9a6d5d04386f5 SHA512 39193ba2c39dc24b234092a47f9834af5b8dff6edc34ba6e0ceb6a4bda60c2f30b951bc17ef72da1dd220ef62563c88f4106dd0115a5bf8e51045abfb96151c6
DIST qp10.5.tar.gz 1670927 BLAKE2B 74fd47beb18f7081ade39bf215a999066a2a5e99753ee8e48751c37d7bff111d355a7713f13af43a1cffc2fa6ca5efdf89a633fba45accdef17ee265f068e57a SHA512 6a7d46f09015304ffa222c82be5d9fb28c272ce27641455113740f3a4a08887369208456c478320b30d9464d8eeea0f7fcc1c1e56e1a130134e2fe54d5446958
25 changes: 25 additions & 0 deletions dev-lang/qu-prolog/files/qu-prolog-10.5-gcc-version.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- qp10.5.orig/configure.in 2019-12-29 00:57:44.000000000 +0100
+++ qp10.5/configure.in 2020-06-25 08:53:32.610430095 +0200
@@ -209,22 +209,6 @@
uname \
)

-#----------------------------------------------------------------------------
-dnl Check for CPP version
-AC_MSG_CHECKING([for GCC version])
-qp_cpp_ver=[`gcc --version 2>/dev/null | head -1 | sed -e 's/^[^[:digit:]]*\([[:digit:]][^[:space:]]*\).*$/\1/'`]
-if test -n "$qp_cpp_ver"; then
- AC_MSG_RESULT($qp_cpp_ver)
- case "$qp_cpp_ver" in
- 2.*)
- AC_DEFINE(GCC_VERSION_2, 1, [Whether or not the GCC is gcc 2])
- ;;
- esac
-else
- AC_MSG_RESULT(not found)
- AC_MSG_ERROR(Could not determine GCC version)
-fi
-
#-----------------------------------------------------------------------------
dnl Check for -fno-strict-aliasing
AC_MSG_CHECKING([for -fno-strict-aliasing])
100 changes: 100 additions & 0 deletions dev-lang/qu-prolog/qu-prolog-10.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,100 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools eutils multilib qmake-utils

MY_P=qp${PV}

DESCRIPTION="Extended Prolog supporting quantifiers, object-variables and substitutions"
HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/QuPrologHome.html"
SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/QPFiles/${MY_P}.tar.gz"

LICENSE="Apache-2.0 GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug doc examples pedro qt5 readline threads"

RDEPEND="
!dev-util/mpatch
!dev-util/rej
qt5? (
dev-qt/qtwidgets:5
dev-qt/qtgui:5
)
pedro? ( net-misc/pedro )
readline? ( app-misc/rlwrap )"
DEPEND="${RDEPEND}
dev-lang/perl"

S="${WORKDIR}"/${MY_P}

src_prepare() {
eapply "${FILESDIR}"/${PN}-10.x-qt5.patch
eapply "${FILESDIR}"/${PN}-10.5-gcc-version.patch
eapply_user

eautoconf
}

src_configure() {
econf \
--libdir=/usr/$(get_libdir) \
$(use_enable debug) \
$(use_enable threads multiple-threads)

if use qt5; then
cd "${S}"/src/xqp || die
eqmake5 xqp.pro
fi
}

src_compile() {
emake OPTIMISATION="${CXXFLAGS}"

if use qt5; then
cd "${S}"/src/xqp || die
emake
fi
}

src_install() {
sed \
-e "s|${S}|/usr/$(get_libdir)/qu-prolog|g" \
-i bin/qc bin/qc1.qup bin/qecat bin/qg bin/qp || die

dobin bin/{qc,qecat,qp,kq}

use qt5 && dobin src/xqp/xqp

into /usr/$(get_libdir)/${PN}
dobin bin/{qa,qc1.qup,qdeal,qem,qg,ql,qppp}

insinto /usr/$(get_libdir)/${PN}/bin
doins bin/rl_commands
doins bin/{qc1.qup,qecat,qg,qp}.qx

insinto /usr/$(get_libdir)/${PN}/library
doins prolog/library/*.qo

insinto /usr/$(get_libdir)/${PN}/compiler
doins prolog/compiler/*.qo

doman doc/man/man1/*.1

dodoc README

if use doc ; then
docinto reference-manual
dodoc doc/manual/*.html
docinto user-guide
dodoc doc/user/main.pdf
fi

if use examples ; then
docinto examples
newdoc examples/README README.examples
dodoc examples/*.ql
fi
}

0 comments on commit 5c4d7da

Please sign in to comment.