forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Keri Harris <[email protected]>
- Loading branch information
1 parent
82c423c
commit 5c4d7da
Showing
3 changed files
with
126 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
--- qp10.5.orig/configure.in 2019-12-29 00:57:44.000000000 +0100 | ||
+++ qp10.5/configure.in 2020-06-25 08:53:32.610430095 +0200 | ||
@@ -209,22 +209,6 @@ | ||
uname \ | ||
) | ||
|
||
-#---------------------------------------------------------------------------- | ||
-dnl Check for CPP version | ||
-AC_MSG_CHECKING([for GCC version]) | ||
-qp_cpp_ver=[`gcc --version 2>/dev/null | head -1 | sed -e 's/^[^[:digit:]]*\([[:digit:]][^[:space:]]*\).*$/\1/'`] | ||
-if test -n "$qp_cpp_ver"; then | ||
- AC_MSG_RESULT($qp_cpp_ver) | ||
- case "$qp_cpp_ver" in | ||
- 2.*) | ||
- AC_DEFINE(GCC_VERSION_2, 1, [Whether or not the GCC is gcc 2]) | ||
- ;; | ||
- esac | ||
-else | ||
- AC_MSG_RESULT(not found) | ||
- AC_MSG_ERROR(Could not determine GCC version) | ||
-fi | ||
- | ||
#----------------------------------------------------------------------------- | ||
dnl Check for -fno-strict-aliasing | ||
AC_MSG_CHECKING([for -fno-strict-aliasing]) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,100 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools eutils multilib qmake-utils | ||
|
||
MY_P=qp${PV} | ||
|
||
DESCRIPTION="Extended Prolog supporting quantifiers, object-variables and substitutions" | ||
HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/QuPrologHome.html" | ||
SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/QPFiles/${MY_P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0 GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="debug doc examples pedro qt5 readline threads" | ||
|
||
RDEPEND=" | ||
!dev-util/mpatch | ||
!dev-util/rej | ||
qt5? ( | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtgui:5 | ||
) | ||
pedro? ( net-misc/pedro ) | ||
readline? ( app-misc/rlwrap )" | ||
DEPEND="${RDEPEND} | ||
dev-lang/perl" | ||
|
||
S="${WORKDIR}"/${MY_P} | ||
|
||
src_prepare() { | ||
eapply "${FILESDIR}"/${PN}-10.x-qt5.patch | ||
eapply "${FILESDIR}"/${PN}-10.5-gcc-version.patch | ||
eapply_user | ||
|
||
eautoconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--libdir=/usr/$(get_libdir) \ | ||
$(use_enable debug) \ | ||
$(use_enable threads multiple-threads) | ||
|
||
if use qt5; then | ||
cd "${S}"/src/xqp || die | ||
eqmake5 xqp.pro | ||
fi | ||
} | ||
|
||
src_compile() { | ||
emake OPTIMISATION="${CXXFLAGS}" | ||
|
||
if use qt5; then | ||
cd "${S}"/src/xqp || die | ||
emake | ||
fi | ||
} | ||
|
||
src_install() { | ||
sed \ | ||
-e "s|${S}|/usr/$(get_libdir)/qu-prolog|g" \ | ||
-i bin/qc bin/qc1.qup bin/qecat bin/qg bin/qp || die | ||
|
||
dobin bin/{qc,qecat,qp,kq} | ||
|
||
use qt5 && dobin src/xqp/xqp | ||
|
||
into /usr/$(get_libdir)/${PN} | ||
dobin bin/{qa,qc1.qup,qdeal,qem,qg,ql,qppp} | ||
|
||
insinto /usr/$(get_libdir)/${PN}/bin | ||
doins bin/rl_commands | ||
doins bin/{qc1.qup,qecat,qg,qp}.qx | ||
|
||
insinto /usr/$(get_libdir)/${PN}/library | ||
doins prolog/library/*.qo | ||
|
||
insinto /usr/$(get_libdir)/${PN}/compiler | ||
doins prolog/compiler/*.qo | ||
|
||
doman doc/man/man1/*.1 | ||
|
||
dodoc README | ||
|
||
if use doc ; then | ||
docinto reference-manual | ||
dodoc doc/manual/*.html | ||
docinto user-guide | ||
dodoc doc/user/main.pdf | ||
fi | ||
|
||
if use examples ; then | ||
docinto examples | ||
newdoc examples/README README.examples | ||
dodoc examples/*.ql | ||
fi | ||
} |