Skip to content

Commit

Permalink
app-office/lyx: Bump to 2.3.6.1
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/765586
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Pacho Ramos <[email protected]>
  • Loading branch information
pacho2 committed Jan 23, 2021
1 parent 57a7e5f commit 5cc7cb2
Show file tree
Hide file tree
Showing 2 changed files with 173 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/lyx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lyx-2.3.5.2.tar.xz 16139804 BLAKE2B e6ea7b2fbec330bfe31b8f88e0a5cc25ff65991421f99b04e98d26945bba48a95f389e2a7e6023d4c9720d43f80136682eb40ac4be51799f01e038e4b0fad206 SHA512 90c5459ad0a77568d588e05a360482985988382927583b14914d6a23b788756e957d0237c18b9ab0681dfc2ad7aa34d21e97304e3a74d19ef047c38f692fba03
DIST lyx-2.3.6.1.tar.xz 16242608 BLAKE2B d59c6db79d7760902f93405e3737974fa9c6bd79c5ab4b02010021532903c76a77701f1f99a0838b4379c548f3f37dcdd9eeb492b733c4162162d868d1d92970 SHA512 233f6c54d4a036ad12f33c6705810bfb99747bdbd015550a8a0a9d7b664d3be50a06dc337191b820c42de4407c5f790efa50c706a45fb2260a71f772fb22c872
172 changes: 172 additions & 0 deletions app-office/lyx/lyx-2.3.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,172 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6..9} )

MY_P="${P/_}"
inherit desktop flag-o-matic font python-single-r1 qmake-utils toolchain-funcs xdg-utils

DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
HOMEPAGE="https://www.lyx.org/"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}.tar.xz
ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.3/${MY_P}/${MY_P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
IUSE="aspell cups debug dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
RDEPEND="${PYTHON_DEPS}
app-text/mythes
dev-libs/boost:=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-texlive/texlive-fontsextra
sys-apps/file
sys-libs/zlib
virtual/imagemagick-tools[png,svg?]
aspell? ( app-text/aspell )
cups? ( net-print/cups )
dia? ( app-office/dia )
dot? ( media-gfx/graphviz )
enchant? ( app-text/enchant:2 )
gnumeric? ( app-office/gnumeric )
html? ( dev-tex/html2latex )
hunspell? ( app-text/hunspell )
l10n_he? ( dev-tex/culmus-latex )
latex? (
app-text/dvipng
app-text/ghostscript-gpl
app-text/ps2eps
app-text/texlive
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexextra
dev-texlive/texlive-mathscience
dev-texlive/texlive-pictures
dev-texlive/texlive-plaingeneric
|| (
dev-tex/hevea
dev-tex/latex2html
dev-tex/tex4ht[java]
dev-tex/tth
)
)
rcs? ( dev-vcs/rcs )
rtf? (
app-text/unrtf
dev-tex/html2latex
dev-tex/latex2rtf
)
svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
"
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
"

DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )

S="${WORKDIR}/${MY_P}"

FONT_S="${S}/lib/fonts"
FONT_SUFFIX="ttf"

pkg_setup() {
python-single-r1_pkg_setup
font_pkg_setup
}

src_prepare() {
default
sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
}

src_configure() {
tc-export CXX
#bug 221921
export VARTEXFONTS="${T}"/fonts

econf \
$(use_with aspell) \
$(use_enable debug) \
$(use_with enchant) \
$(use_with hunspell) \
$(use_enable monolithic-build) \
$(use_enable nls) \
--enable-qt5 \
--with-qt-dir=$(qt5_get_libdir)/qt5 \
--disable-stdlib-debug \
--without-included-boost \
--with-packaging=posix
}

src_install() {
default

if use l10n_he ; then
echo "\bind_file cua" > "${T}"/hebrew.bind || die
echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind || die

insinto /usr/share/lyx/bind
doins "${T}"/hebrew.bind
fi

newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
doicon -s 48 "lib/images/lyx.png"
doicon -s scalable "lib/images/lyx.svg"

# fix for bug 91108
if use latex ; then
dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
fi

# fonts needed for proper math display, see also bug #15629
font_src_install

python_fix_shebang "${ED}"/usr/share/${PN}

if use hunspell ; then
dosym ../myspell /usr/share/lyx/dicts
dosym ../myspell /usr/share/lyx/thes
fi
}

pkg_postinst() {
font_pkg_postinst
xdg_icon_cache_update
xdg_desktop_database_update

# fix for bug 91108
if use latex ; then
texhash || die
fi

# instructions for RTL support. See also bug 168331.
if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
elog
elog "Enabling RTL support in LyX:"
elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
elog "You must enable RTL support in LyX. To do so start LyX and go to"
elog "Tools->Preferences->Language settings->Language"
elog "and make sure the \"Right-to-left language support\" is checked"
elog
fi
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update

if use latex ; then
texhash || die
fi
}

0 comments on commit 5cc7cb2

Please sign in to comment.