Skip to content

Commit

Permalink
dev-vcs/git-cola: add 4.4.1
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/920572
Bug: https://bugs.gentoo.org/920534
Signed-off-by: Martin Gysel <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
bearsh authored and thesamesam committed Dec 23, 2023
1 parent 209ad09 commit 5cdb2bd
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/git-cola/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST git-cola-4.0.1.tar.gz 1018819 BLAKE2B 523264bbee38526d12db5ad975d78c72ef6c0
DIST git-cola-4.1.0.tar.gz 1140393 BLAKE2B 3236e06f86d23a7311e3cd639cbf2adcecb18810abcae938d1ff7cf25b477d814e614fffa20ce39dd9a2c6ab4f8e6b6b67f3ad3144163abe6530ac227313ca98 SHA512 4d2617947d4dbf3273f02c072de5ede10a656981f3653273780e2c1b1d3d613cd359fbb93cfb0a1d5de24b0c90818503cd9041ad3fa1a05b2ecd2db305bbe1a0
DIST git-cola-4.2.1.tar.gz 1191680 BLAKE2B 8dd9d4b52672e32deba2f54e7f9141d3364dcbf3a823b05e766f333063a26cc49ea9e5e2f43f9492447b6b7344c930a2a1160653fb2699ff7d23cb22783f4cd1 SHA512 1a9d63c985d3566f81edd3ed3debc4d499fa5147650d479f3b1bc833d08836a17d63a8eb23c1cd5c2c31f6f7202219fb77cacb628df8f85dd3d367dcdd110891
DIST git-cola-4.3.1.tar.gz 1205221 BLAKE2B 01a481569f603f2760d2200467721ccff0a03931ecc762d320be8c7071b81539b3d1bab089284168bfba2d34ab210366c59bf252b3a028ccd1733d0899a724dc SHA512 35d1fd877a27199ee3fbf6cf6ded0754370c23b6d198eb79422f95c21e2c8cb058671af27776c9c207bdb0d6fa0114ddc713654a2e91b2931c5000a9e5573f6c
DIST git-cola-4.4.1.tar.gz 1212338 BLAKE2B 8f95720fa8af0acdecf744f657808b969f914bfd1cb2ccd2ed3af35f2811ab8aca7022ba888e0fc447a685af4c7dba27a0f0305f0b2d07cc31ccd22953d4fa14 SHA512 3e4e1cb8cd148b34e663c72c6b3d1e887815b5a86558ffbf13a19a5dfd3fb6b37c123290dc514b6f098893587dc67ca34424aaad5482768795e353f0efe92797
66 changes: 66 additions & 0 deletions dev-vcs/git-cola/git-cola-4.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_SINGLE_IMPL=true
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 readme.gentoo-r1 virtualx xdg

DESCRIPTION="The highly caffeinated git GUI"
HOMEPAGE="https://git-cola.github.io/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]
dev-python/QtPy[gui,network,${PYTHON_USEDEP}]
dev-python/send2trash[${PYTHON_USEDEP}]
')
dev-vcs/git
"
BDEPEND="sys-devel/gettext
$(python_gen_cond_dep "
dev-python/setuptools-scm[\${PYTHON_USEDEP}]
test? (
${VIRTUALX_DEPEND}
dev-python/pytest[\${PYTHON_USEDEP}]
dev-python/PyQt5[\${PYTHON_USEDEP},gui,widgets]
)
")
"

distutils_enable_sphinx docs \
'dev-python/rst-linker'
distutils_enable_tests pytest

src_prepare() {
sed -i "s|doc/git-cola =|doc/${PF} =|" setup.cfg || die
distutils-r1_src_prepare
}

src_test() {
virtx distutils-r1_src_test
}

python_test() {
cd "${T}" || die
GIT_CONFIG_NOSYSTEM=true LC_ALL="C.utf8" \
epytest "${S}"/test
}

src_compile() {
SETUPTOOLS_SCM_PRETEND_VERSION=${PV} distutils-r1_src_compile
}

src_install() {
distutils-r1_src_install
readme.gentoo_create_doc
}

0 comments on commit 5cdb2bd

Please sign in to comment.