Skip to content

Commit

Permalink
media-sound/pnmixer: version bump to 0.7.2
Browse files Browse the repository at this point in the history
- Make gettext dependency optional, controlled by the nls USE flag
- New doc USE flag, for building the documentation using doxygen

Closes: https://bugs.gentoo.org/657242
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
diogocp authored and a17r committed Jul 6, 2018
1 parent eefaa28 commit 5cf14cf
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/pnmixer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pnmixer-0.6_pre20111213.tar.xz 131328 BLAKE2B dabfa6e8270116eb325dc6dfd59c6f650975f1efce27603b0495f11efebd743aaba17ad19efba82d4c1d75753418a89295277853c9095d6a4fffdf6b17c5b9fe SHA512 967a685593256f9f2e8ab2ef955a91a03c3710d96956087ac55301d5232e6f01897efbb064bd6dc1804836af1b66c038cb3d04203043462de5246e4f14dd37c4
DIST pnmixer-0.7.1.tar.gz 237949 BLAKE2B 87b309f3dd844009abe5f5bb2c5ca16ba80069932c2833a9d472130a6f0d7c36a050dc393bca097372c44fca5f90742cfad07c40a6f51ff877080f5eee25b2d2 SHA512 08d83424d921ef6112700fe8c3b55e147ace7767698a9d3ee4bb79ed0e727be7bcc82d55d3debc4b805e75f07c5702443be157e1bccce44d76072c36f8825816
DIST pnmixer-v0.7.2.tar.gz 237972 BLAKE2B 368d149d9e803b52c7b0edac9ba8996312da7122f10f536095cffcdf31d319159494fa3aab0005e6dedb4e7e0b46d58bc73dd89285c7bddca4750d29539fa489 SHA512 9f43a56d17f4c16465113d4355a546ba71ca4d208e384812cf84625a51bd9bb6fa0e93f3e40fd0a2d157c4ee2b27f64082a47bbd4135c168a95b3fcbeebf6186
51 changes: 51 additions & 0 deletions media-sound/pnmixer/pnmixer-0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils gnome2-utils

MY_PV="v${PV}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="Volume mixer for the system tray"
HOMEPAGE="https://github.com/nicklan/pnmixer"
SRC_URI="https://github.com/nicklan/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc libnotify nls"

RDEPEND="dev-libs/glib:2
media-libs/alsa-lib
x11-libs/gtk+:3
x11-libs/libX11
libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
app-doc/doxygen
media-gfx/graphviz
)
nls? ( sys-devel/gettext )"

S=${WORKDIR}/${MY_P}

src_configure() {
local mycmakeargs=(
-DWITH_LIBNOTIFY="$(usex libnotify)"
-DENABLE_NLS="$(usex nls)"
-DBUILD_DOCUMENTATION="$(usex doc)"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
cmake-utils_src_configure
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 5cf14cf

Please sign in to comment.