Skip to content

Commit

Permalink
sys-fs/btrfs-progs: bump up to 4.3.1, bug #567052
Browse files Browse the repository at this point in the history
Reported-by: Nick Bowler
Bug: https://bugs.gentoo.org/567052

Package-Manager: portage-2.2.25
  • Loading branch information
Sergei Trofimovich committed Nov 29, 2015
1 parent 1065556 commit 5d31777
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/btrfs-progs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST btrfs-progs-v4.1.2.tar.xz 1123080 SHA256 62db60c6a0868afb6302112cea54c75687
DIST btrfs-progs-v4.1.tar.xz 1119564 SHA256 abc6ff9dbbf948e7358edd34db32103cba8b86c5cb9e3ed7eb3b5630e2feb7e8 SHA512 0c596bab3276d1dc6de010ce94a1d7758c80fe21d540b2d4b3487e0a5cf0a63b27fdba3e1af42aa349447a0be459f2087f9b4ae03fdc0dfcc4f316e570893346 WHIRLPOOL 97ae77f578f162ec114e137899f195ec0e28097902e2f2ae5e1f37db359cd6c1bae2f0fb6641b0365df80defb844d58603623db27dc63c1576437efcaf19d3e6
DIST btrfs-progs-v4.2.2.tar.xz 1143760 SHA256 5d87e4ebb2a3a288c167791e489bfa484034d185c704870c484cb0771d921316 SHA512 2ad23546b3bb421faad1f67da37566b6ae1887c5340c0f1d06ca59fc0cd0fb1060d92e74e36ba7bfd85b0aff30811525654cd03b7d3570b0b51c2d8e2d6d9a76 WHIRLPOOL 5051f232bf5d6c2d19bc0fba9f2653546fc09000279863637a7ab44ff5c8bd107e5307aef3d2fbc7113581df3c224965f882045153eb9fa10da5b34cc4318188
DIST btrfs-progs-v4.2.tar.xz 1130488 SHA256 25233c3e94c52bf433e8749c17dad2acd8004c6dbc93e2bff9397c4e9fa58fbe SHA512 ba322478c1ce4df5548a953de581053c9fb9d60d1626639dc543065847a0c92ea6712728479dcb59487e02ab6aaea9f688fe1e3ef5087517e55d346b02d36065 WHIRLPOOL 54cd45554c15bedac3baac6939e6e91965b59c1c6cc0b7ca10d4c910dfe56811a278f9ee6026a9cc61286544370a45f0c0ccccfb08d7958d7a0c4b2964751bd4
DIST btrfs-progs-v4.3.1.tar.xz 1184416 SHA256 0cb5ff15deed01cdf5a77f3f61b7dc9d2cd6787bcf6b6b7dcef424d16e8afd3a SHA512 661c7c05ee3527cc34f3aa08e88e252e6e836a86752f7e607e3f6dc0a9a861d3bc645a6fa0a5af5f6abfe4f3f2f7e193cffc2bb1c53595e0b7f99c3ff59daeff WHIRLPOOL 503ab00d8362ab2b4b9b91a8de18cca9eba1d76f2331f54cbecc7e89cc491dce3cfbd761d8e6e37773499cea7ef67a66dc7f544d7590d0c82acbef90ebe0c824
81 changes: 81 additions & 0 deletions sys-fs/btrfs-progs/btrfs-progs-4.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit bash-completion-r1 eutils multilib toolchain-funcs

libbtrfs_soname=0

if [[ ${PV} != 9999 ]]; then
MY_PV=v${PV}
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
S="${WORKDIR}"/${PN}-${MY_PV}
else
WANT_LIBTOOL=none
inherit autotools git-r3
EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git
https://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
EGIT_BRANCH="devel"
fi

DESCRIPTION="Btrfs filesystem utilities"
HOMEPAGE="https://btrfs.wiki.kernel.org"

LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
IUSE="+convert"

RESTRICT=test # tries to mount repared filesystems

RDEPEND="
dev-libs/lzo:2=
sys-libs/zlib:0=
convert? (
sys-fs/e2fsprogs:0=
sys-libs/e2fsprogs-libs:0=
)
"
DEPEND="${RDEPEND}
convert? ( sys-apps/acl )
app-text/asciidoc
app-text/docbook-xml-dtd:4.5
app-text/xmlto
"

if [[ ${PV} == 9999 ]]; then
DEPEND+=" sys-devel/gnuconfig"
fi

src_prepare() {
epatch_user
if [[ ${PV} == 9999 ]]; then
eautoreconf
mkdir config || die
local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
[[ -e ${automakedir} ]] || die "Could not locate automake directory"
ln -s "${automakedir}"/install-sh config/install-sh || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.guess config/config.guess || die
ln -s "${EPREFIX}"/usr/share/gnuconfig/config.sub config/config.sub || die
fi
}

src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
$(use_enable elibc_glibc backtrace)
)
econf "${myeconfargs[@]}"
}

src_compile() {
emake V=1
}

src_install() {
default
newbashcomp btrfs-completion btrfs
}

0 comments on commit 5d31777

Please sign in to comment.