Skip to content

Commit

Permalink
dev-python/scandir: Works with py3.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.70, Repoman-2.3.16
Signed-off-by: Alexey Shvetsov <[email protected]>
  • Loading branch information
alexxy committed Aug 4, 2019
1 parent 10bcf6a commit 5d55fb3
Showing 1 changed file with 23 additions and 0 deletions.
23 changes: 23 additions & 0 deletions dev-python/scandir/scandir-1.10.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )

inherit distutils-r1

DESCRIPTION="A better directory iterator and faster os.walk()"
HOMEPAGE="https://github.com/benhoyt/scandir"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
}

0 comments on commit 5d55fb3

Please sign in to comment.