Skip to content

Commit

Permalink
dev-cpp/catch: Bump to 1.9.5
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jun 16, 2017
1 parent bfce41f commit 5d56439
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/catch/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Catch-1.9.4.tar.gz 363097 SHA256 d67d2ee26ec9f72618dd9b28a9d1b7ba3c6368bc846ecfeda05a1e5d1b8b9b20 SHA512 78d43719e87f5d27132178c5f139b72e6093dd1029eb742bfb48e32b618079e156837fb25d4cbe0fd5044535a5a65ad90510cff8ae93f2695c7bb3fc5cb2a5ec WHIRLPOOL 80b4c36172e62ea12fc4acee096a84cd00b1a290dc2a7a9e9a8e2ff2485e39a619e33f2aee853daa7773d3c877f55788b2d0f86e44542c6f8c0b6027edaf0585
DIST Catch-1.9.5.tar.gz 366036 SHA256 455e5bc5f81aa8ddf25f264b794e13f5dc8182e9ab057324409fb4c7dbe686a0 SHA512 b093f5b4e5a9bf7d099739c4f222741b8f56ab6d880d86d62d37320d64e4f41aa4d6f3f6c7da55ab9772fa3ddb415a420564fa03774fb01424a5243665eba12f WHIRLPOOL 98f526681e0a6f15ea9cf4e64753afae1e3b53115544955f1b484b2fd2e7a6a7b4b44d0e86b459af69356157b8256045a354450646b184adf41d95ad831e62b8
34 changes: 34 additions & 0 deletions dev-cpp/catch/catch-1.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="Modern C++ header-only framework for unit-tests"
HOMEPAGE="https://github.com/philsquared/Catch"
SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"

LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

S=${WORKDIR}/${P^}

# CMake is only used to build & run tests, so override phases
src_configure() { :; }
src_compile() { :; }

src_test() {
cmake-utils_src_configure
cmake-utils_src_compile
cmake-utils_src_test
}

src_install() {
# same location as used in fedora
insinto /usr/include/catch
doins -r include/.
dodoc -r docs/.
}

0 comments on commit 5d56439

Please sign in to comment.