Skip to content

Commit

Permalink
dev-lang/xsb: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Keri Harris <[email protected]>
  • Loading branch information
keriharris committed Jul 17, 2020
1 parent 770fed2 commit 5d600ae
Show file tree
Hide file tree
Showing 2 changed files with 200 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-lang/xsb/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST XSB360.tar.gz 12842882 BLAKE2B 734d17a05eb9cb79906a98a77a6562a9445603a884523689c1f2e5e5f9cd4ebfc7182e9ecde9bf9f97c18a90bc4d0d35a2344ac92193d9ee43eb733530571836 SHA512 2ac2f4d4c7501479648b7f618815d4cd996969791a617f2148ef7498cf08bacd67eab298136303b6804cb689129ae3365e1490ec693f2232f9c9f1ad515d9c6c
DIST XSB370.tar.gz 12322913 BLAKE2B 64db80704ce656bfaa402d161a94c7b1cd3119a363e848b2c7768665df580b25f1fc43b49b381960d9049d947590b7eb3c846c1a2d6b8a1233d8eb2c4de04f7e SHA512 e2c11b0e5fbbffc2fb6d493e39b7dd74de43509ea1c844f1b3e5d1002c116d6fb8b245905b7b512499e40765a6603d4bef883052bdeec4a3078011c305f85a9f
DIST XSB38.tar.gz 13830570 BLAKE2B 60a6ab38435348d09e2d08bc65ca62c06b38495b72f40a6f3f10fe8d23949bfed0c580c9be0c8304d8a88a53b227bb695870b558d67f33a47543de6c1529180f SHA512 457c691450afcf3ed4e2fffc28deaef0949ef4bbf6fd69b504acc6507fbb144f2c6e427a25da2b6346b15b82e803c02d1b6962af698d16c1fcb9a3d56160ea30
DIST xsb-3.6.0-gentoo-patchset-4.tar.gz 7513 BLAKE2B cf846dc94e0f1194f5da381b888f4ce6476a4e861cb23e6dca87b0cd2c0ea24c4290ea080432d2c5440f7350cf0862c7fc34e303a8dfe824e2e3e06f29aa4815 SHA512 bb7ba7836fa2df7a54fd2837b4cb760f7ae0e9511bc0a4b2be8cba89ed4aeedda6712937a4748bd9e9ee16366d442fd962a121dbf83017e2199eb3a287efb1d5
DIST xsb-3.7.0-gentoo-patchset-3.tar.gz 5636 BLAKE2B f7b66131d3f02fd75e8b6019f8e64cb6f531155116364da432df41a8f7b3ba2b8d300f7b64bbcae7a755478c6aeb637b36457b491998c88457a96b64e5ecb46e SHA512 bee6d62b900c9ee3a373dfa0ad7362b18c748bb9e0559a878534ed517067d753e1fa79277b0588133a1eeceafcd56b4dcc9ff81892309f6c6666150baaaaf047
DIST xsb-3.8.0-gentoo-patchset-0.tar.gz 6527 BLAKE2B 8b9efe0612c1a7cabb2987d95c55b659333fcb7c7ec7b5c31f839ef86485d74c46b477632f060d6a2221bfdfb1eb1dabdf4a61b512ffd2bd3fd4d2cc70192e76 SHA512 a8ce81751c3e391bff3e0bf2c8b90eb0887a2cbc5aa2e0f5f6ba80ea4dfbfb677422453b2dde814d50dc0ba0b1adfcecff7589008b06c62834d9093da6cea29c
198 changes: 198 additions & 0 deletions dev-lang/xsb/xsb-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,198 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PATCHSET_VER="0"

inherit autotools java-pkg-opt-2

DESCRIPTION="XSB is a logic programming and deductive database system"
HOMEPAGE="http://xsb.sourceforge.net"
SRC_URI="http://xsb.sourceforge.net/downloads/XSB38.tar.gz
https://dev.gentoo.org/~keri/distfiles/xsb/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"

LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="curl debug iodbc java mysql odbc pcre threads xml"

RDEPEND="curl? ( net-misc/curl )
iodbc? ( dev-db/libiodbc )
java? ( >=virtual/jdk-1.4:= )
mysql? ( dev-db/mysql-connector-c:0= )
odbc? ( dev-db/unixODBC )
pcre? ( dev-libs/libpcre )
xml? ( dev-libs/libxml2 )"

DEPEND="${RDEPEND}"

S="${WORKDIR}"/XSB

PATCHES=( "${WORKDIR}/${PV}" )

src_prepare() {
default
cd "${S}"/build
eautoconf
}

src_configure() {
cd "${S}"/build

econf \
--prefix=/usr/$(get_libdir) \
--disable-optimization \
--disable-ccmpl \
--without-smodels \
$(use_with odbc) \
$(use_with iodbc) \
$(use_enable threads mt) \
$(use_enable debug)

if use curl ; then
cd "${S}"/packages/curl
econf
fi

if use mysql ; then
cd "${S}"/packages/dbdrivers/mysql
econf
fi

if use odbc ; then
cd "${S}"/packages/dbdrivers/odbc
econf
fi

if use pcre ; then
cd "${S}"/packages/pcre
econf
fi

if use xml ; then
cd "${S}"/packages/xpath
econf
fi
}

src_compile() {
cd "${S}"/build

default

# All XSB Packages are compiled using a single Prolog engine.
# Consequently they must all be compiled using a single make job.

cd "${S}"/packages
rm -f *.xwam
emake -j1

if use curl ; then
emake -j1 curl
emake -j1 sgml
if use xml ; then
emake -j1 xpath
fi
fi

if use mysql ; then
emake -j1 mysql
fi

if use odbc ; then
emake -j1 odbc
fi

if use pcre ; then
emake -j1 pcre
fi
}

src_install() {
cd "${S}"/build
default

local XSB_INSTALL_DIR=/usr/$(get_libdir)/xsb-${PV}
dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb

cd "${S}"/packages
local PACKAGES=${XSB_INSTALL_DIR}/packages
insinto ${PACKAGES}
doins *.xwam

insinto ${PACKAGES}/chr
doins chr/*.xwam

insinto ${PACKAGES}/clpqr
doins clpqr/*.xwam

insinto ${PACKAGES}/gap
doins gap/*.xwam

insinto ${PACKAGES}/justify
doins justify/*.xwam
doins justify/*.H

insinto ${PACKAGES}/regmatch
doins regmatch/*.xwam
insinto ${PACKAGES}/regmatch/cc
doins regmatch/cc/*.H

insinto ${PACKAGES}/slx
doins slx/*.xwam

insinto ${PACKAGES}/wildmatch
doins wildmatch/*.xwam
insinto ${PACKAGES}/wildmatch/cc
doins wildmatch/cc/*.H

if use curl ; then
insinto ${PACKAGES}/curl
doins curl/*.xwam
insinto ${PACKAGES}/curl/cc
doins curl/cc/*.H
insinto ${PACKAGES}/sgml
doins sgml/*.xwam
insinto ${PACKAGES}/sgml/cc
doins sgml/cc/*.H
insinto ${PACKAGES}/sgml/cc/dtd
doins sgml/cc/dtd/*
if use xml ; then
insinto ${PACKAGES}/xpath
doins xpath/*xwam
insinto ${PACKAGES}/xpath/cc
doins xpath/cc/*.H
fi
fi

if use mysql || use odbc ; then
insinto ${PACKAGES}/dbdrivers
doins dbdrivers/*.xwam
doins dbdrivers/*.H
insinto ${PACKAGES}/dbdrivers/cc
doins dbdrivers/cc/*.H
if use mysql ; then
insinto ${PACKAGES}/dbdrivers/mysql
doins dbdrivers/mysql/*.xwam
insinto ${PACKAGES}/dbdrivers/mysql/cc
doins dbdrivers/mysql/cc/*.H
fi
if use odbc ; then
insinto ${PACKAGES}/dbdrivers/odbc
doins dbdrivers/odbc/*.xwam
insinto ${PACKAGES}/dbdrivers/odbc/cc
doins dbdrivers/odbc/cc/*.H
fi
fi

if use pcre ; then
insinto ${PACKAGES}/pcre
doins pcre/*.xwam
insinto ${PACKAGES}/pcre/cc
doins pcre/cc/*.H
fi

cd "${S}"
dodoc FAQ README
}

0 comments on commit 5d600ae

Please sign in to comment.