forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-server/monopd: version bump; drop ppc due to missing dep
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Jan 8, 2016
1 parent
63e0b49
commit 5d6fa1a
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST monopd-0.10.2.tar.gz 180317 SHA256 252da82002ea27015cb53f9ded04c63838b237c9d254d1b504af56249ed75fdb SHA512 f47d9623e110a98d9d32b522484944998fb6e7e8644e1f2b439428a1e12b3b514b902e52e7135150135a3e3251aa38604434347d06533f3cf3ffb28a2a81ede3 WHIRLPOOL 5f42874cbc51bf2209bf0328b4df348832a808faa101a50b323b8ce8b12c9eacf70684738819da16115c30244b1dfe1a94f0b98b177cfe9ad615f734a4db5641 | ||
DIST monopd-0.9.7.tar.gz 180318 SHA256 34aa975c8ee410f661622f91a63c4199e68a333123218b3e48300be1bc7afc30 SHA512 55b2e3b6f16f20fc1928d79eaecbdceaf9b9a8c9fe44b2cf8a8489347c728a006df78043235504e3931bb71b90e7493375fb2b71285447ad4a11dd434aa3133f WHIRLPOOL 14c47c95b64fafe07dc37ea61579ad42cf09c535f35b8f22d7dbdfa1dd04c529173e22c99287d2c748266ab00cdd82e28340d945924681849a1209911d6fcd16 | ||
DIST monopd-0.9.8.tar.gz 180509 SHA256 408321ea73f2e7cdee570973ff50a3ee1a2f7078f8f19e8861614f238574ec9a SHA512 c39806c51f27eb29f154db520bf1c49d10e5a8587b3d23411de43bd07cd3553c398ea31802473d9cdcf350f5432abeb7bde62478e1844abc93d73395951c87b1 WHIRLPOOL 9e18cfac665610f5372af16128b87095eeb19251cd511b489124c4e7d8845bcc123c6a1fc51d8d457cdabf6cacc6dcf704766b8ff1a96c0f5940bd4f66595272 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit autotools eutils systemd games | ||
|
||
DESCRIPTION="server for atlantik games" | ||
HOMEPAGE="http://gtkatlantic.gradator.net/" | ||
SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="systemd" | ||
|
||
RDEPEND="systemd? ( sys-apps/systemd )" | ||
DEPEND="${RDEPEND} | ||
>=dev-cpp/muParser-2 | ||
dev-libs/utfcpp" | ||
|
||
src_prepare() { | ||
sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \ | ||
"${FILESDIR}"/monopd.in > "${T}"/monopd || die | ||
sed -i \ | ||
-e "s:/usr/sbin:${GAMES_BINDIR}:" \ | ||
doc/systemd/monopd.service || die | ||
sed -i \ | ||
-e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \ | ||
configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
egamesconf $(use_with systemd systemd-daemon) | ||
} | ||
|
||
src_install() { | ||
default | ||
doinitd "${T}"/monopd | ||
systemd_dounit doc/systemd/monopd.s* | ||
prepgamesdirs | ||
} |