Skip to content

Commit

Permalink
dev-scheme/gauche: fix tests
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
hattya committed Nov 29, 2016
1 parent 1826786 commit 5d83e86
Show file tree
Hide file tree
Showing 3 changed files with 25 additions and 2 deletions.
5 changes: 3 additions & 2 deletions dev-scheme/gauche/files/gauche-0.9-rfc.tls.patch
Original file line number Diff line number Diff line change
@@ -1,11 +1,12 @@
--- Gauche-0.9.3.2.orig/ext/tls/Makefile.in
+++ Gauche-0.9.3.2/ext/tls/Makefile.in
@@ -77,6 +77,8 @@
@@ -77,6 +77,9 @@
@sed -e "s@\.\./ssl/@../../$(srcdir)/axTLS/ssl/@g" \
-e "s/system/safe_system/g" \
-e "s@openssl @sh ../../$(srcdir)/kick_openssl @g" \
+ -e "/do_reneg = 1;/i#if 0" \
+ -e "/do_reneg = 0;/a#endif" \
+ -e "/do_reneg = 0;/a#endif" \
+ -e "/SSL_server_test(/,/)/s/ -tls1//" \
$(srcdir)/axTLS/ssl/test/ssltest.c >> $(SSLTEST_GENERATED)
@cat $(srcdir)/system-fix.c >> $(SSLTEST_GENERATED)

21 changes: 21 additions & 0 deletions dev-scheme/gauche/files/gauche-0.9.3.3-file.util.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
commit 15fb279dccb83d66d7e866a0e6f4e3f9ff64fd8d
Author: Shiro Kawai <[email protected]>
Date: Thu Nov 29 23:17:55 2012 -1000

Fix file.util test

The current test may fail when a size of a directory happens to
100. Patch from NIIBE Yutaka.

--- a/ext/file/test.scm
+++ b/ext/file/test.scm
@@ -290,7 +290,8 @@
(reverse
(directory-fold "test.out"
(^[path result]
- (if (= (file-size path) 100)
+ (if (and (file-is-regular? path)
+ (= (file-size path) 100))
(cons path result)
result))
'()
1 change: 1 addition & 0 deletions dev-scheme/gauche/gauche-0.9.3.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.9-xz-info.patch
"${FILESDIR}"/${PN}-0.9-rfc.tls.patch
"${FILESDIR}"/${P}-gauche.threads.patch
"${FILESDIR}"/${P}-file.util.patch
)

src_prepare() {
Expand Down

0 comments on commit 5d83e86

Please sign in to comment.