forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-arch/engrampa: Update p7zip support
Package-Manager: portage-2.3.0
- Loading branch information
1 parent
541b17d
commit 5d84164
Showing
4 changed files
with
148 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
GCONF_DEBUG="yes" | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit gnome2 versionator | ||
|
||
MATE_BRANCH="$(get_version_component_range 1-2)" | ||
|
||
SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz" | ||
DESCRIPTION="Engrampa archive manager for MATE" | ||
HOMEPAGE="http://mate-desktop.org" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
|
||
IUSE="caja magic" | ||
|
||
RDEPEND=">=x11-libs/gtk+-2.24.0:2 | ||
>=dev-libs/glib-2.32.0:2 | ||
>=dev-libs/json-glib-0.14:0 | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/pango:0 | ||
virtual/libintl:0 | ||
caja? ( >=mate-base/caja-1.10:0 ) | ||
magic? ( sys-apps/file ) | ||
!!app-arch/mate-file-archiver" | ||
|
||
DEPEND="${RDEPEND} | ||
>=dev-util/intltool-0.35:* | ||
dev-util/itstool:0 | ||
>=mate-base/mate-common-1.8:0 | ||
sys-devel/gettext:* | ||
virtual/pkgconfig:*" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-1.10.2-p7zip-15.09-compat.patch" | ||
"${FILESDIR}/${PN}-1.10.2-p7zip-15.14-compat.patch" | ||
) | ||
|
||
src_prepare() { | ||
gnome2_src_prepare | ||
|
||
# Drop DEPRECATED flags as configure option doesn't do it, bug #385453 | ||
sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \ | ||
copy-n-paste/Makefile.am copy-n-paste/Makefile.in || die | ||
} | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--disable-run-in-place \ | ||
--disable-packagekit \ | ||
--disable-deprecations \ | ||
--with-gtk=2.0 \ | ||
$(use_enable caja caja-actions) \ | ||
$(use_enable magic) | ||
} | ||
|
||
DOCS="AUTHORS HACKING MAINTAINERS NEWS README TODO" | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
|
||
elog "" | ||
elog "${PN} is a frontend for several archiving utilities. If you want a" | ||
elog "particular achive format supported install the relevant package." | ||
elog | ||
elog "For example:" | ||
elog " 7-zip : emerge app-arch/p7zip" | ||
elog " ace : emerge app-arch/unace" | ||
elog " arj : emerge app-arch/arj" | ||
elog " cpio : emerge app-arch/cpio" | ||
elog " deb : emerge app-arch/dpkg" | ||
elog " iso : emerge app-cdr/cdrtools" | ||
elog " jar,zip : emerge app-arch/zip or emerge app-arch/unzip" | ||
elog " lha : emerge app-arch/lha" | ||
elog " lzma : emerge app-arch/xz-utils" | ||
elog " lzop : emerge app-arch/lzop" | ||
elog " rar : emerge app-arch/unrar" | ||
elog " rpm : emerge app-arch/rpm" | ||
elog " unstuff : emerge app-arch/stuffit" | ||
elog " zoo : emerge app-arch/zoo" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
25 changes: 25 additions & 0 deletions
25
app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.09-compat.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
From 4f65bde8fc4d4efe747d4e7fbeba1211469ed79a Mon Sep 17 00:00:00 2001 | ||
From: monsta <[email protected]> | ||
Date: Thu, 24 Dec 2015 17:11:19 +0300 | ||
Subject: [PATCH] 7z: correct checking for p7zip 15.09+ | ||
|
||
from https://github.com/GNOME/file-roller/commit/ed9c3fd2 | ||
|
||
fixes https://github.com/mate-desktop/engrampa/issues/114 | ||
--- | ||
src/fr-command-7z.c | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/src/fr-command-7z.c b/src/fr-command-7z.c | ||
index 297ba1b..0b784f7 100644 | ||
--- a/src/fr-command-7z.c | ||
+++ b/src/fr-command-7z.c | ||
@@ -106,7 +106,7 @@ list__process_line (char *line, | ||
strncpy (version, ver_start, ver_len); | ||
version[ver_len] = 0; | ||
|
||
- if (strcmp (version, "4.55") < 0) | ||
+ if ((strcmp (version, "4.55") < 0) && (ver_len > 1) && (version[1] == '.')) | ||
p7z_comm->old_style = TRUE; | ||
else | ||
p7z_comm->old_style = FALSE; |
30 changes: 30 additions & 0 deletions
30
app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.14-compat.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
From a2a537eb4c263a5b33851572a189fe89476b212e Mon Sep 17 00:00:00 2001 | ||
From: sc0w <[email protected]> | ||
Date: Wed, 25 May 2016 02:29:21 +0200 | ||
Subject: [PATCH] p7zip-rar 15.14 supported | ||
|
||
since 15.14, p7zip-rar uses the plugin Rar.so to handle archives | ||
|
||
It can find on /usr/lib/ or /usr/libexec/ | ||
|
||
If someone has it in another folder, we can add it | ||
|
||
Fixes #136 | ||
--- | ||
src/fr-command-7z.c | 3 ++- | ||
1 file changed, 2 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/src/fr-command-7z.c b/src/fr-command-7z.c | ||
index 20cfa2c..a7d032e 100644 | ||
--- a/src/fr-command-7z.c | ||
+++ b/src/fr-command-7z.c | ||
@@ -599,7 +599,8 @@ fr_command_7z_get_capabilities (FrCommand *comm, | ||
if (is_mime_type (mime_type, "application/x-rar") | ||
|| is_mime_type (mime_type, "application/x-cbr")) | ||
{ | ||
- if (! check_command || g_file_test ("/usr/lib/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS)) | ||
+ if (! check_command || g_file_test ("/usr/lib/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS) || g_file_test ("/usr/lib/p7zip/Codecs/Rar.so", G_FILE_TEST_EXISTS) | ||
+ || g_file_test ("/usr/libexec/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS) || g_file_test ("/usr/libexec/p7zip/Codecs/Rar.so", G_FILE_TEST_EXISTS)) | ||
capabilities |= FR_COMMAND_CAN_READ; | ||
} | ||
else |