Skip to content

Commit

Permalink
net-misc/qtm: Version bump 1.3.18
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Acked-by: Michael Palimaka <[email protected]>
Closes: gentoo#37

Signed-off-by: Johannes Huber <[email protected]>
  • Loading branch information
johu committed Feb 5, 2017
1 parent 0f65911 commit 5d9a327
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/qtm/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qtm-1.3.17.tar.bz2 185310 SHA256 c5cab3e1386e1f7b49cc6711252b1e311a0872e1888b8bdfebaeecf61b52cc85 SHA512 b01568cec8e1550caf06958f196c1d3558511b6dbb32209ae83c4aa401f55fbeff093431103b52aa7ffba903afebd32906008c0c021565df478c2281010d921a WHIRLPOOL a95f1a37df357360594fb19b603ded8654ed086b4b8b65649fb3f739c4dc96079c7b88e31f8a053d722448574cddc11f32626afc8d4e7f7e7460512cb42ca291
DIST qtm-1.3.18.tar.bz2 186137 SHA256 c10fcae059a8e05d83f215b9e718dd2ce7e51ade0c94809ec335faf7527af3d2 SHA512 d4685f22a883e1d7513dcac57a807b0d21c26dfceda547b22889ee980758de1a49c2e898c745bb597efd709823d96da59f7494015c0915edb34e9141fa60e2ca WHIRLPOOL d0af2b33b36097f1cffab9c33f65cc80b12341a3fc954a978561b177ae86472e0565d7dbe1d330519ca70dd47f38d2ef1a1d41351063b1e334d61ee1cf89dd00
53 changes: 53 additions & 0 deletions net-misc/qtm/qtm-1.3.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

CMAKE_IN_SOURCE_BUILD="1"
inherit cmake-utils versionator

DESCRIPTION="Qt blogging client"
HOMEPAGE="http://qtm.blogistan.co.uk"
SRC_URI="https://bitbucket.org/IndigoJo/${PN}-$(get_version_component_range 1-2)/downloads/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus debug"
RESTRICT="strip"

RDEPEND="dev-lang/perl
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
virtual/perl-Digest-MD5
x11-proto/xproto
dbus? ( dev-qt/qtdbus:5 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

DOCS=( Changelog README )

src_prepare() {
# bug 463810
sed -i -e '/Categories/s/Application;//' qtm-desktop.sh || die 'sed on qtm-desktop.sh failed'

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DQt5=ON
-DDONT_USE_PTE=OFF
-DINSTALL_MARKDOWN=ON
-DNO_SSL=OFF
-DUSE_DBUS=$(usex dbus)
-DDONT_USE_DBUS=$(usex !dbus)
-DQDEBUG=$(usex debug)
)

cmake-utils_src_configure
}

0 comments on commit 5d9a327

Please sign in to comment.