Skip to content

Commit

Permalink
app-containers/skopeo: Bump to version 1.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Feb 18, 2022
1 parent a364ffd commit 5da4dfa
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-containers/skopeo/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST skopeo-1.3.0.tar.gz 5593261 BLAKE2B b26e39d821e63b31a1cbd23bf7b836fbe3185f4
DIST skopeo-1.3.1.tar.gz 5595931 BLAKE2B eda2767a1b1b899b99fc70ef361541c388cab77d4521cc2792baf78ca2474e73ff2d7d64d26f713410a40600866fd6c20855d4acdbdb0a31b11d7efaa8101b83 SHA512 65b8ba735bd409b25b56a5538de4e09edfd11d684752a6e9d28037d0f2b80aef80796c2e9588fcf192d24bd885cc7b2d65b0ee7f7c34d18b2eacc25816da5d36
DIST skopeo-1.5.1.tar.gz 5636533 BLAKE2B 7f0e86cdee5c3250ec1280d7e71554ac2f8ad96ababe0e81dfabc00e8c128a13fc0c9c561b7a9be389d7386e9f664b95118bd2122612b9c2e8844db49769c03c SHA512 3f8c730eaa739bf2a29b82d3b04aa4eee1c09f957b61964fc8c48e59d1537bcb87b5bdf9c18fa48f9d36cf2b7ede3a1448918a20b5a3167f6ce09881a6cd3dde
DIST skopeo-1.6.0.tar.gz 6542541 BLAKE2B d2898d8f80a04340e3174179e2397f7b5e66ed50ec8c11919adf1b0620c74a3a69f8be548c5c3bf081735e1a86dc5ae3390d058ef64fc4b73d8f01074ef4a210 SHA512 13a3660780ce43e31a9840811aaa7626f9d0de9999e52c469a2a58b4bf96bd5e4d67e0f0556ac2baef14c5a662afae1f2d407b260c8833d573326791a2193e48
DIST skopeo-1.6.1.tar.gz 6543397 BLAKE2B 25ca8bc99b03516cb2312c5ce36c13ec87ad34f3831a04e37d5c0f5d4afe2a60ae5d8e6039d8d3651b978459cbdec65f6f43259116368a11b8c6d3478b8ca733 SHA512 92ebe121ae41b2f192e52e24ae05a2f12fedf3483f8d342f6bdde9cb902a291e0297b187c614a64a5c1a62098c7dc59d8a5e5fd1f61b48e4030b163822b47a2b
52 changes: 52 additions & 0 deletions app-containers/skopeo/skopeo-1.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
COMMIT=49084d2cd8c9f8e7b38ba8405d61e701d5381bc0
inherit go-module bash-completion-r1

DESCRIPTION="Command line utility foroperations on container images and image repositories"
HOMEPAGE="https://github.com/containers/skopeo"
SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="btrfs"

COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
>=dev-libs/libassuan-2.4.3:=
dev-libs/libgpg-error:=
btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
>=sys-fs/lvm2-2.02.145:="
DEPEND="${COMMON_DEPEND}
dev-go/go-md2man"
RDEPEND="${COMMON_DEPEND}"

RESTRICT+=" test"

src_compile() {
local BUILDTAGS
BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
-gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
-o skopeo ./cmd/skopeo
echo "$@"
"$@" || die
cd docs || die
for f in *.1.md; do
go-md2man -in ${f} -out ${f%%.md} || die
done
}

src_install() {
dobin skopeo
doman docs/*.1
dobashcomp completions/bash/skopeo
insinto /etc/containers
newins default-policy.json policy.json
insinto /etc/containers/registries.d
doins default.yaml
keepdir /var/lib/atomic/sigstore
einstalldocs
}

0 comments on commit 5da4dfa

Please sign in to comment.