forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/prelude-manager: Bump version 3.1.0
- Loading branch information
Showing
4 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST prelude-manager-3.0.0.tar.gz 1286459 SHA256 379de4c79ccdba4093e9c5a2b9e5c6cee8e8d8694e1358c3d248250c4957dc0b SHA512 4c16a353495179265375686ce9592c8cd044b4255060b78286466bd25f9b38634233c95af058e1c0b81e1b574ec9ada5b2db92d6d1f5594dfcddce572fd0fd67 WHIRLPOOL 35814a88e62e4bfdbd3e8c88f733cd304f8fb355d820ae9887da0c9e6b02936b7aed8d73a05cc458fbf01f7a9e48174d446b1174e1edd44637fadcdc282f3f92 | ||
DIST prelude-manager-3.1.0.tar.gz 1301799 SHA256 e5d0dbe306c5473fb5ea86d465595eca2c3d7c74b13c9dcf8786bbbc6e36ae0d SHA512 75df43f9db81d2b6bd87c649eda7bb30ee10510576473bea83cb5cce44f576e9d69d775b5d76dcea8841eee61730a97cdae51e6c8b3a426d2442c5183d0e0d10 WHIRLPOOL 05b6b619f7ddabcbf970e38e9c3af90b8cf6274b694caa276891f2743ea8b991f724f7f5dbbe9867afda1bba3b59d07525fca7f0fe03b0594f8ea0c796f33ce7 |
13 changes: 13 additions & 0 deletions
13
app-admin/prelude-manager/files/prelude-manager-3.1.0-run.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
When : everytime | ||
Why : Fix the run dir to comply with the Gentoo FS layout. | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -337,7 +337,7 @@ | ||
|
||
manager_failover_dir=$LOCALSTATEDIR/spool/prelude-manager/failover | ||
manager_scheduler_dir=$LOCALSTATEDIR/spool/prelude-manager/scheduler | ||
-manager_run_dir=$LOCALSTATEDIR/run/prelude-manager | ||
+manager_run_dir=/run/prelude-manager | ||
|
||
AC_DEFINE_UNQUOTED(REPORT_PLUGIN_DIR, "$report_plugin_dir", Prelude-Manager report plugin directory) | ||
AC_DEFINE_UNQUOTED(DECODE_PLUGIN_DIR, "$decode_plugin_dir", Prelude-Manager decode plugin directory) |
Empty file.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools systemd | ||
|
||
DESCRIPTION="Bus communication for all Prelude modules" | ||
HOMEPAGE="https://www.prelude-siem.org" | ||
SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="tcpwrapper xml geoip dbx" | ||
|
||
RDEPEND="net-libs/gnutls:= | ||
~dev-libs/libprelude-${PV} | ||
dbx? ( ~dev-libs/libpreludedb-${PV} ) | ||
tcpwrapper? ( sys-apps/tcp-wrappers ) | ||
xml? ( dev-libs/libxml2 ) | ||
geoip? ( dev-libs/libmaxminddb )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-run.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--localstatedir="${EPREFIX}/var" \ | ||
$(use_with dbx libpreludedb-prefix) \ | ||
$(use_with tcpwrapper libwrap) \ | ||
$(use_with xml xml-prefix) \ | ||
$(use_enable geoip libmaxminddb) | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
rm -rv "${ED%/}/run" || die "rm failed" | ||
keepdir /var/spool/prelude-manager{,/failover,/scheduler} | ||
|
||
find "${D}" -name '*.la' -delete || die | ||
|
||
systemd_dounit "${FILESDIR}/${PN}.service" | ||
systemd_newtmpfilesd "${FILESDIR}/${PN}.run" "${PN}.conf" | ||
|
||
newinitd "${FILESDIR}/${PN}.initd" "${PN}" | ||
} |