Skip to content

Commit

Permalink
dev-libs/xapian: version bump to 1.4.12
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <[email protected]>
  • Loading branch information
blueness committed Aug 20, 2019
1 parent 83b9a3a commit 5dda5eb
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/xapian/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,6 +2,7 @@ DIST xapian-core-1.2.24.tar.xz 3210192 BLAKE2B 062f0c15ce87fb64b0eec5e5e54b76c44
DIST xapian-core-1.2.25.tar.xz 3253292 BLAKE2B a130e26188c949d0433d017e8d13e7ecf6241a232d00125699ba8ed63eab9cb1651e02182fcc152f960f4e122709958632779daaaf5760fe50953a3b5b07a243 SHA512 a15b5d9b5770337519f671732f53f0642b31f08206824500d589ba309c9e91a05a30353d66ebf70a4c1cb1824b44e1c7b7630e799de3b15d645cf951a6017bfe
DIST xapian-core-1.4.10.tar.xz 2973780 BLAKE2B 6ef86a4c02e6721f434e33ea27a37ddac9cee62f0c9eed8c6334cadb62dd544be66405dd359dd944cf1ab12742c10e786b7300c4987e33ce33da9d9df4e428d4 SHA512 fa716d6f8c04edb297d99dad4d7835f7874837ab3c39d7017e43708cde6992c596e579418be17b79772e002bd23b94169812523a1abd9519b1dd3df474f027d9
DIST xapian-core-1.4.11.tar.xz 2975524 BLAKE2B c912e527ef1454c0b4b3e1aedd91a8a63d2e0b2dd186759eac00d6a0f64104669467c6c5b0bf3f132d4fa04bb2ef72d07ccfe92137a3360ba699e3420ee8bea4 SHA512 72ab7b0c774390f38319d241689b2dc3c2837fbbf933616574f6ad167f14a25c2eff747910022065508dc7c44f806dc2b71dae80a1b4f1f47e1675fb951bc785
DIST xapian-core-1.4.12.tar.xz 2979052 BLAKE2B 26b20b22105493679052827a5e6b2890da922cdaa97fca1266b26f6ddb3de6b76d491c37ca10210ef5119ce4250700d87fdd22553456958f6869bc3af51b78ae SHA512 230b39e012366267cf5ea09d01d3b463818c0d05861b8c8643bc6fc238be21bd3f4862adeba864b4af2962b1c0748b3d380dfe845da467f5164b0d938288c430
DIST xapian-core-1.4.5.tar.xz 2810612 BLAKE2B 7784e69e3ca064751d829173949fcde65661c2c2070fdc8392cf2b6d40874a3e5b1265e61f25dd39b33e179b3fe3842b67f33a55523c3a18e9b65528e6a23a1e SHA512 cff97a856a406583ca81164ddb704a0eeae7d8d6f94ce3b3f53d5208d657423e87dd06bdc7acb5e5904765bce1cefbc98365cde315c1d46f7b18cfba7b022ae6
DIST xapian-core-1.4.7.tar.xz 2874172 BLAKE2B 917a35ca717ed4437f4a617ce0b6ac07d5936e07aac6bfa9d6878c12ed0c38e7ca994ad943b6dc7a5cd2fe131a445c5a7859f2286c2201dd048020569ce1a0bf SHA512 9e77a78bd63036966ebb9bbed91e36fef17b37c9465c8d4b7dc8041f0e24b040e6520de645babfeeade952771d145176a204328718cfa8bc2291bb6fdbe840d2
DIST xapian-core-1.4.8.tar.xz 2880432 BLAKE2B 8468a33614d8c7617755cfe4cc79e72ab42612a79be9fb684525e268efe80c42ce902a60a44dc5548c70b719d752e15927ce24b4ab457905022ae806bffb1f11 SHA512 9ed1f34ec1bf53a4dc628ebb8d080af79a4ac6a315bf1ae52441f0ac3a63e5478ed02887382116b28157b926e685fdc730489426edce560aa4bba27cb7295e48
Expand Down
78 changes: 78 additions & 0 deletions dev-libs/xapian/xapian-1.4.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit eutils multilib-minimal

MY_P="${PN}-core-${PV}"

DESCRIPTION="Xapian Probabilistic Information Retrieval library"
HOMEPAGE="https://www.xapian.org/"
SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"

LICENSE="GPL-2"
SLOT="0/30" # ABI version of libxapian.so
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-solaris"
IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +inmemory +remote"

DEPEND="sys-libs/zlib"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

multilib_src_configure() {
local myconf=""

if use cpu_flags_x86_sse2; then
myconf="${myconf} --enable-sse=sse2"
else
if use cpu_flags_x86_sse; then
myconf="${myconf} --enable-sse=sse"
else
myconf="${myconf} --disable-sse"
fi
fi

myconf="${myconf} $(use_enable static-libs static)"

use glass || myconf="${myconf} --disable-backend-glass"
use inmemory || myconf="${myconf} --disable-backend-inmemory"
use remote || myconf="${myconf} --disable-backend-remote"

myconf="${myconf} --enable-backend-chert --program-suffix="

ECONF_SOURCE=${S} econf $myconf
}

MULTILIB_WRAPPED_HEADERS=(
/usr/include/xapian/postingsource.h
/usr/include/xapian/attributes.h
/usr/include/xapian/valuesetmatchdecider.h
/usr/include/xapian/version.h
/usr/include/xapian/version.h
/usr/include/xapian/types.h
/usr/include/xapian/positioniterator.h
/usr/include/xapian/registry.h
)

multilib_src_test() {
emake check VALGRIND=
}

multilib_src_install() {
emake DESTDIR="${D}" install
}

multilib_src_install_all() {
# bug #573466
dosym xapian-config /usr/bin/xapian-config-1.3

if use doc; then
rm -rf "${D}/usr/share/doc/xapian-core-${PV}" || die
fi

dodoc AUTHORS HACKING PLATFORMS README NEWS

find "${D}" -name "*.la" -type f -delete || die
}

0 comments on commit 5dda5eb

Please sign in to comment.