Skip to content

Commit

Permalink
app-admin/longrun: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 29, 2017
1 parent 15ad544 commit 5df1867
Show file tree
Hide file tree
Showing 3 changed files with 28 additions and 33 deletions.
15 changes: 7 additions & 8 deletions app-admin/longrun/files/0.9-makefile_cflags.patch
Original file line number Diff line number Diff line change
@@ -1,14 +1,13 @@
Common subdirectories: longrun.old/debian and longrun/debian
diff -u longrun.old/Makefile longrun/Makefile
--- longrun.old/Makefile 2005-08-12 22:36:14.186390784 +0300
+++ longrun/Makefile 2005-08-12 22:37:36.157929216 +0300
@@ -3,7 +3,7 @@
--- a/Makefile
+++ b/Makefile
@@ -2,8 +2,8 @@

all: longrun README stamp-po

longrun: longrun.c
-longrun: longrun.c
- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" -W -Wall -o longrun longrun.c
+CFLAGS += -W -Wall
+CPPFLAGS += -DLOCALEDIR=\"$(LOCALEDIR)\"

README: longrun.1
groff -Tascii -man longrun.1 | col -bx > README
Common subdirectories: longrun.old/po and longrun/po
38 changes: 17 additions & 21 deletions app-admin/longrun/longrun-0.9-r4.ebuild
Original file line number Diff line number Diff line change
@@ -1,54 +1,50 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

inherit eutils linux-info toolchain-funcs
EAPI=6

inherit linux-info toolchain-funcs

DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
HOMEPAGE="http://freshmeat.net/projects/longrun/"

DEBIAN_PATCH_VERSION="19"
DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff.gz"
DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff"
SRC_URI="
mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2
mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}"
mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-ppc x86"
IUSE=""

DEPEND=""
DEPEND="sys-apps/groff"

S=${WORKDIR}/${PN}

CONFIG_CHECK="~X86_MSR ~X86_CPUID"

ERROR_X86_MSR="
Longrun needs a MSR device to function. Please select
MSR under Processor type and features. It can be build
directly into the kernel or as a module.
"

directly into the kernel or as a module."
ERROR_X86_CPUID="
Longrun needs a CPUID device to function. Please select
CPUID under Processor type and features. It can be
build directly into the kernel or as a module.
"
build directly into the kernel or as a module."

src_unpack() {
unpack ${P}.tar.bz2
cd "${S}"
epatch "${DISTDIR}/${DEBIAN_PATCH}"
epatch "${FILESDIR}/${PV}-makefile_cflags.patch"
epatch "${FILESDIR}/${PV}-replace-loff_t.patch"
}
PATCHES=(
"${WORKDIR}"/${DEBIAN_PATCH}
"${FILESDIR}"/${PV}-makefile_cflags.patch
"${FILESDIR}"/${PV}-replace-loff_t.patch
)

src_compile() {
emake CC="$(tc-getCC)" || die "emake failed"
src_configure() {
tc-export CC
}

src_install() {
make DESTDIR="${D}" install || die "make install failed"
default
dodoc MAKEDEV-cpuid-msr
}

Expand Down
8 changes: 4 additions & 4 deletions app-admin/longrun/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>
Longrun is a user space utility program for controlling the Longrun
thermal and power save functionalities found in the processors made
by Transmeta.
</longdescription>
Longrun is a user space utility program for controlling the Longrun
thermal and power save functionalities found in the processors made
by Transmeta.
</longdescription>
<upstream>
<remote-id type="freshmeat">longrun</remote-id>
</upstream>
Expand Down

0 comments on commit 5df1867

Please sign in to comment.