Skip to content

Commit

Permalink
dev-libs/elfutils: fix build w/ lld 17
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/913112
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Aug 29, 2023
1 parent 064cfd0 commit 5e484e2
Show file tree
Hide file tree
Showing 2 changed files with 156 additions and 0 deletions.
125 changes: 125 additions & 0 deletions dev-libs/elfutils/elfutils-0.189-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,125 @@
# Copyright 2003-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/elfutils.gpg
inherit autotools flag-o-matic multilib-minimal verify-sig

DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
HOMEPAGE="https://sourceware.org/elfutils/"
SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
SRC_URI+=" verify-sig? ( https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2.sig )"

LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="bzip2 debuginfod lzma nls static-libs test +utils zstd"
RESTRICT="!test? ( test )"

RDEPEND="
!dev-libs/libelf
>=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}]
bzip2? ( >=app-arch/bzip2-1.0.6-r4[static-libs?,${MULTILIB_USEDEP}] )
debuginfod? (
app-arch/libarchive:=
dev-db/sqlite:3=
net-libs/libmicrohttpd:=
net-misc/curl[static-libs?,${MULTILIB_USEDEP}]
)
lzma? ( >=app-arch/xz-utils-5.0.5-r1[static-libs?,${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[static-libs?,${MULTILIB_USEDEP}] )
elibc_musl? (
dev-libs/libbsd
sys-libs/argp-standalone
sys-libs/fts-standalone
sys-libs/obstack-standalone
)
"
DEPEND="
${RDEPEND}
"
BDEPEND="
>=sys-devel/flex-2.5.4a
sys-devel/m4
nls? ( sys-devel/gettext )
verify-sig? ( sec-keys/openpgp-keys-elfutils )
"

PATCHES=(
"${FILESDIR}"/${PN}-0.189-PaX-support.patch
"${FILESDIR}"/${PN}-0.189-skip-DT_RELR-failing-tests.patch
"${FILESDIR}"/${PN}-0.189-musl-aarch64-regs.patch
"${FILESDIR}"/${PN}-0.189-musl-macros.patch
"${FILESDIR}"/${P}-configure-bashisms.patch
"${FILESDIR}"/${P}-clang16-tests.patch
"${FILESDIR}"/${P}-tests-run-lfs-symbols.sh-needs-gawk.patch
"${FILESDIR}"/${P}-lld-17.patch
)

src_prepare() {
default

# Only here for ${P}-configure-bashisms.patch, delete on next bump!
eautoreconf

if ! use static-libs; then
sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
fi

# https://sourceware.org/PR23914
sed -i 's:-Werror::' */Makefile.in || die
}

src_configure() {
# bug #407135
use test && append-flags -g

multilib-minimal_src_configure
}

multilib_src_configure() {
local myeconfargs=(
$(use_enable nls)
$(multilib_native_use_enable debuginfod)
$(use_enable debuginfod libdebuginfod)

# explicitly disable thread safety, it's not recommended by upstream
# doesn't build either on musl.
--disable-thread-safety

# Valgrind option is just for running tests under it; dodgy under sandbox
# and indeed even w/ glibc with newer instructions.
--disable-valgrind
--program-prefix="eu-"
--with-zlib
$(use_with bzip2 bzlib)
$(use_with lzma)
$(use_with zstd)
)

# Needed because sets alignment macro
is-flagq -fsanitize=address && myeconfargs+=( --enable-sanitize-address )
is-flagq -fsanitize=undefined && myeconfargs+=( --enable-sanitize-undefined )

ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
LC_ALL="C" \
emake check VERBOSE=1
}

multilib_src_install_all() {
einstalldocs

dodoc NOTES

# These build quick, and are needed for most tests, so don't
# disable their building when the USE flag is disabled.
if ! use utils; then
rm -rf "${ED}"/usr/bin || die
fi
}
31 changes: 31 additions & 0 deletions dev-libs/elfutils/files/elfutils-0.189-lld-17.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
https://bugs.gentoo.org/913112
https://sourceware.org/PR30729
https://sourceware.org/git/?p=elfutils.git;a=commit;h=09e61a65953ed814d9e970f7f9ffb9c2d8cda477

From 09e61a65953ed814d9e970f7f9ffb9c2d8cda477 Mon Sep 17 00:00:00 2001
From: Mark Wielaard <[email protected]>
Date: Mon, 28 Aug 2023 20:23:41 +0200
Subject: [PATCH] libelf: Remove elf_scncnt from libelf.map

elf_scncnt was never implemented. It was probably an old name for
elf_getshnum (which was the deprecated name of the elf_getshdrnum
alias). Just remove it from the map file

* libelf/libelf.map (ELFUTILS_1.0): Remove elf_scncnt.

https://sourceware.org/PR30729

Reported-by: Kostadin Shishmanov <[email protected]>
Signed-off-by: Mark Wielaard <[email protected]>
--- a/libelf/libelf.map
+++ b/libelf/libelf.map
@@ -50,7 +50,6 @@ ELFUTILS_1.0 {
elf_rand;
elf_rawdata;
elf_rawfile;
- elf_scncnt;
elf_strptr;
elf_update;
elf_version;
--
2.39.3

0 comments on commit 5e484e2

Please sign in to comment.