Skip to content

Commit

Permalink
dev-python/stormpath: add version 2.1.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
Alex Brandt committed Nov 7, 2015
1 parent 9efd3bf commit 5e4912c
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/stormpath/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST stormpath-2.0.9.tar.gz 4325976 SHA256 ba93f1f9f6b98db2eb2671d2b3285fdd15f8b2e6d3bce899f240576018f216ae SHA512 b50fa11e8fecf4909a8a1014963c80e7e2dde4db37e1f4681c2a116933d59f5b5ea32901cfde97b24398d8074db8b04121b2a7715d86b6b2eb78eb288465114c WHIRLPOOL 6290d5844d35158cc46f1810b6f83e41c443164cff4512caeeb38e562b04f448c1ac1b608b2cda4abd348f91319e4e8fbb3b195ba31a8fb415ba80f0ed7c5937
DIST stormpath-2.1.1.tar.gz 4326557 SHA256 94600e8368f2fbe06adea5fddc8f4b7a479f7a89a0a35a46f58f7c796286e5f4 SHA512 7548aff63e5f04718d4d4887a1177f6f0cf3cc8cb9588e17f7563bae9c6dc5897a968ee2c4e189b6d9100ef16ec7e34e524c4cd3c5112845c0619876ca6d5505 WHIRLPOOL 33db1d8e52d24581a1fe7220b4329479142772939d1df76d52a46d47db6219890fde3204655dd65851d43b38e2427cd32df894392948482d85554772b9f12bbf
DIST stormpath-2.1.2.tar.gz 4337164 SHA256 10f46c7ebb27274f61c4b550eb6fc58e54260fa0fb1f96a4b7fce530d789d11c SHA512 c3b3e93f4d5515df8e5ab94770c995a5e7912a53f58f05ca3a1f630c41fc0f76e39cf213dbfad8858d7bfe5f964f6d9cbfad9013de33e9a02e0484bd92a7957d WHIRLPOOL adfbf1cf071167a93989cd4d80039a4eb8c42a908075207a4db4db3a38c87e3b9470b9c1c02946e9481e52d875e836d0c77a72050de2a1f79fc78b5ed037dfe2
DIST stormpath-2.1.4.tar.gz 4338169 SHA256 adbc595b243861be0268c2c71061de8ce6dc8f9a92d7398f92bf77a734315b2f SHA512 6834f1b8db731872208c96b9acb2ff66e5d7fcbb6ae0c1f1de541ce1597a786834f2b68c43d00c5adcb1018749c53b45444dde2a81a520fed79fd9b6f0f07ab0 WHIRLPOOL 6f50a1f6476d4486f43da55ae48c56942ef90820db4434c3b567222cb65d56aaa5649249dfc10add807f5ccba245d99b89efa031201af61bc888b902cf66b4ea
51 changes: 51 additions & 0 deletions dev-python/stormpath/stormpath-2.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_3 python3_4 )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"
RDEPEND="
>=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
>=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
>=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
>=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
>=dev-python/six-1.6.1[${PYTHON_USEDEP}]
"

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
esetup.py test
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit 5e4912c

Please sign in to comment.