Skip to content

Commit

Permalink
app-misc/jira-cli: Version bump to 2.1.5
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
mrueg committed Feb 13, 2017
1 parent 4073382 commit 5e6d676
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/jira-cli/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jira-cli-2.1.4.tar.gz 122946 SHA256 dca0cca199108bd4eab4b539fafca2012fed5c21caf6732c60c20aebf7cf1bc1 SHA512 83cb24d0773d3afd0f2370df49a7e9154fa7d50bdbd1828bf836c868d61b40d0ac5f03fdafe865af14896514ee0b8afe96d738bee222725f6483c0773e33ab0e WHIRLPOOL ce6c6bc8af66771f13649d038a0540bf5e4a2f2847ddbfc0b3753c6be625ca03862325e795dc5f3f6458cbdcaa1de48a900a63209c0a26f190897771fabf0c5f
DIST jira-cli-2.1.5.tar.gz 122947 SHA256 bb0799ea575bc7c60fc800fb4790a3f82f68967eb06cc445a03b852227d92a88 SHA512 8d8cad01d93fcca63ac9420856bca4825bba1e1954e674378c2a3f501c7716125afbda96c5ef12ba4d90e4e771b1d80165aaff1db883af5706510476bd9d8799 WHIRLPOOL fa773d9343191c5cb116a0ea18627f9000289fcf53230ba563b402e432625326c8848c61909b72d62bf9e0e8b6e16b7aefbb9b3a8ef6132b0ee2552f42daf767
47 changes: 47 additions & 0 deletions app-misc/jira-cli/jira-cli-2.1.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4} )

inherit distutils-r1

DESCRIPTION="Simple command line utility to interact with your jira instance"
HOMEPAGE="https://github.com/alisaifee/jira-cli"
SRC_URI="https://github.com/alisaifee/jira-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

RDEPEND="${CDEPEND}
dev-python/requests[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/jira[${PYTHON_USEDEP},oauth]
dev-python/suds[${PYTHON_USEDEP}]
>=dev-python/keyring-10.0.2-r1[${PYTHON_USEDEP}]
dev-python/keyrings_alt[${PYTHON_USEDEP}]"

DEPEND="${CDEPEND}
test? ( ${RDEPEND}
>=dev-python/coverage-4.0.3[${PYTHON_USEDEP}]
dev-python/hiro[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/vcrpy-1.7.4[${PYTHON_USEDEP}] )"

RESTRICT="test"

python_prepare_all() {
sed -i -e '/ordereddict/d' -e '/argparse/d' requirements/main.txt || die
distutils-r1_python_prepare_all
}

python_test() {
nosetests || die
}

0 comments on commit 5e6d676

Please sign in to comment.