Skip to content

Commit

Permalink
x11-plugins/wmsmixer: EAPI7, improve ebuild, use HTTPs
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and voyageur committed Jun 12, 2018
1 parent 9ce5126 commit 5f211ab
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions x11-plugins/wmsmixer/wmsmixer-0.5.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
HOMEPAGE="https://www.dockapps.net/wmsmixer"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

RDEPEND="x11-libs/libXpm
x11-libs/libXext
x11-libs/libX11"
DEPEND="${RDEPEND}
x11-base/xorg-proto"

src_compile() {
$(tc-getCXX) ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
rm -f wmsmixer || die
$(tc-getCXX) ${LDFLAGS} -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
}

src_install() {
insinto /usr/bin
insopts -m0655
doins wmsmixer
dodoc README README.wmmixer
}

0 comments on commit 5f211ab

Please sign in to comment.