Skip to content

Commit

Permalink
dev-go/gopls: bump to 0.9.1
Browse files Browse the repository at this point in the history
Closes: gentoo#26594
Signed-off-by: Randall T. Vasquez <[email protected]>
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
ran-dall authored and zmedico committed Jul 26, 2022
1 parent 0ae9dbf commit 5f2f170
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-go/gopls/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST gopls-0.8.3-deps.tar.xz 22577604 BLAKE2B 762d0eabc16771439fbd0d8cd2018e201a
DIST gopls-0.8.3.tar.gz 3036967 BLAKE2B feb8ee9dae8eed6ebccddaa8425db20a2e6964af3a537e6cfe9e1bf71dc62a6301516b7114e4e33470f82afa27041bc20c7362a1cd5840da0168ce43bc356023 SHA512 b5be84e3ce79f98f2109ca421cfa913a5031518a068d673b6eec8ec5f61a7bd204ae6e7e11af7f4bf94a6f60107d4268359ed3b2751b3df5a98e685de78147b8
DIST gopls-0.9.0-deps.tar.xz 21748784 BLAKE2B dfbe63c2c830548e2c7ed02563d59e0e0c09e3b05da570532d16f9f6b8c9fe4be2c43d6266de69e19b91bbc4f43ff20d768e45b24739e5f6c5e3d0da03ada834 SHA512 60ac489b49812e62cd9758acb6a44adfa8091322684770cbc8fdf048764eda52f9e93bfb4247700cf9480c71e8e16254e9a74102d6ae60a51e647ede5bd5d928
DIST gopls-0.9.0.tar.gz 3101189 BLAKE2B 11b24db6dca208212444df1e25d65700dd814344bbcf66a9a4d08d5a16f18f5040195dfc27628b3020628d3ad79e9d890e218016b66a473cdbab0b415daf6bd3 SHA512 c0dc0fdffec517115acf8e7ce3de1d5357d467f2ea23e070ea800a43a137be67094e69f5f366613dcbb771379818789c2105b2b59f53c04762146876d12f74ea
DIST gopls-0.9.1-deps.tar.xz 21987952 BLAKE2B 3279c9bb5223460ea4881ad2d4061a7eaf973682af26f8af3f6a19436310bd7037ec4e31594e019b2cf17e51784945d89808bd9fccaebbf654b4865383fddef2 SHA512 d29177bab21a27c67ea664f7b1264b5a9ce889d597fa150a9c008a10b0609186fccaae3a0cf6330cf0e88e0fb98c010546be7364486696d0ccebbaf9e5256043
DIST gopls-0.9.1.tar.gz 3101075 BLAKE2B a9e05f28868f733c9ef60bbdf3c6b54f2507eae6b23d18a85d7fd0df69ff3c5fe2806a280a918763aa6e34db7e4d6ca4e3160c7c280e5e9d95511a3ad3846ee6 SHA512 f5a3863dacc5639e1773ee70608d0c22228e348d00cda5303044ad13c6be0d212b64f3866d541459e8e188461bd84e4b2270d5e40baa105f9f0c749db86df9ab
40 changes: 40 additions & 0 deletions dev-go/gopls/gopls-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit go-module

ARCHIVE_URI="https://github.com/golang/tools/archive/refs/tags/gopls/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
DESCRIPTION="\"Go please\" is the official Go language server"
HOMEPAGE="https://github.com/golang/tools/blob/master/gopls/README.md"
SLOT="0"
LICENSE="BSD"
BDEPEND=">=dev-lang/go-1.18"
SRC_URI="
${ARCHIVE_URI}
https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz
"
# TODO: fix test failure with deps tarball
RESTRICT+=" test"

S=${WORKDIR}/tools-gopls-v${PV}/${PN}

src_prepare() {
default
rm internal/regtest/misc/vendor_test.go || die
}

src_compile() {
GOBIN="${S}/bin" CGO_ENABLED=0 go install ./...
[[ -x bin/${PN} ]] || die "${PN} build failed"
}

src_test() {
go test -work "./..." || die
}

src_install() {
dobin bin/${PN}
dodoc -r doc README.md
}

0 comments on commit 5f2f170

Please sign in to comment.