forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-base/gnome-settings-daemon: bump to 3.23.90
Blocks older gnome-session, because the daemon was split up into several smaller daemons, but old gnome-session requires the big settings daemon. Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
3 changed files
with
297 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gnome-settings-daemon-3.20.2.tar.xz 1620696 SHA256 1dd7a084449a2c240308d253f86d60f3efe25f59322c3f5ec3b9e2e9f5eabb45 SHA512 b23ac4cfc5c1fe4b1eeb4ba37cae448b2a23e11b988ae609c3d23168a9c22502829b68a4ab5fc8291bde91b429fcb4159c0f37bef78437838de6c6f3417817ed WHIRLPOOL 94463af0fcc3c3e36ded002e359aa1049d8a6171ae9b7edbf1e3ceeda5f1d2ee9389c09fa2929c2197b20a48fa613cc35fb31dc3eed30feec5f370868b1b4e49 | ||
DIST gnome-settings-daemon-3.22.1.tar.xz 1622420 SHA256 b57d97cdd992263baffa78ccecbbf9f5a9771dd994f19687353d6eec4fd636ba SHA512 7afd550d5e018524e1aadad540d85816d4f42245af025356d079c28fe78754120b3b0d1de2746603331122659e1f43496d5a1160db069e4b1e9669c3404619b2 WHIRLPOOL d9cb415c3874ba9e650dbfc95d3482b83f6dab8ce2fb17a98e4c892230d8e82a34acb43bbb7fe2d620864d09a068dd32467f08063e7fe56a3589d30acfe83159 | ||
DIST gnome-settings-daemon-3.23.90.tar.xz 1614204 SHA256 c9e860558a8132763f6441f317e1df47fc5fe64bc5517bcc9ff9d44a08824fac SHA512 995eae1876df7918746a0050fd4fa08fd50d6bef9e0c5474da33eb5fd7fc53a1f4214179035f6b0716f60620f198697cef4eaf70cb24c510ce5a30cfc761bdcb WHIRLPOOL 45b21a328a57c08fd6872fd1b7e1df30a5f2a47ffd2dc32d41b85ccc3e7c0937c505aa9aa7b21910140759c0f30d90bc5a9afba773547755805866822cf061fb |
145 changes: 145 additions & 0 deletions
145
gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.23.90-optional.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,145 @@ | ||
From 22f6a45b665e604f874e82a817d45bb976d8c5ae Mon Sep 17 00:00:00 2001 | ||
From: Timo Tambet <[email protected]> | ||
Date: Sat, 25 Feb 2017 14:48:19 +0200 | ||
Subject: [PATCH 1/1] [PATCH] Make colord and wacom support optional | ||
|
||
--- | ||
configure.ac | 56 +++++++++++++++++++++++++++++++---------------- | ||
plugins/Makefile.am | 9 ++++++-- | ||
plugins/dummy/Makefile.am | 5 ++++- | ||
3 files changed, 48 insertions(+), 22 deletions(-) | ||
|
||
diff --git a/configure.ac b/configure.ac | ||
index 0d169c8f..792195aa 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -158,13 +158,23 @@ PKG_CHECK_MODULES(CLIPBOARD, | ||
gtk+-x11-3.0 | ||
x11) | ||
|
||
-PKG_CHECK_MODULES(COLOR, | ||
- colord >= 1.0.2 | ||
- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION | ||
- libcanberra-gtk3 | ||
- libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION | ||
- lcms2 >= $LCMS_REQUIRED_VERSION | ||
- libnotify) | ||
+AC_ARG_ENABLE([color], | ||
+ AS_HELP_STRING([--disable-color], | ||
+ [turn off color plugin]), | ||
+ [], | ||
+ [enable_color=yes]) | ||
+ | ||
+AS_IF([test "$enable_color" = "yes"], | ||
+ [PKG_CHECK_MODULES(COLOR, | ||
+ colord >= 1.0.2 | ||
+ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION | ||
+ libcanberra-gtk3 | ||
+ libgeoclue-2.0 >= $GEOCLUE_REQUIRED_VERSION | ||
+ lcms2 >= $LCMS_REQUIRED_VERSION | ||
+ libnotify) | ||
+ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled]) | ||
+ ]) | ||
+AM_CONDITIONAL(BUILD_COLOR, test "x$enable_color" = "xyes") | ||
|
||
PKG_CHECK_MODULES(DATETIME, | ||
libnotify >= $LIBNOTIFY_REQUIRED_VERSION | ||
@@ -268,23 +278,31 @@ case $host_os in | ||
if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then | ||
have_wacom=no | ||
else | ||
- if test x$enable_gudev != xno; then | ||
- LIBWACOM_PKG="libwacom >= $LIBWACOM_REQUIRED_VERSION" | ||
- PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION]) | ||
- PKG_CHECK_MODULES(WACOM, [gtk+-3.0 pango >= $PANGO_REQUIRED_VERSION]) | ||
- PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0]) | ||
- else | ||
+ have_wacom=no | ||
+ AS_IF([test "$enable_gudev" != "no"], | ||
+ [AC_ARG_ENABLE([wacom], | ||
+ AS_HELP_STRING([--disable-wacom], | ||
+ [turn off wacom plugin]), | ||
+ [], | ||
+ [enable_wacom=no]) dnl Default value | ||
+ AS_IF([test "$enable_wacom" = "xyes"], | ||
+ [ | ||
+ PKG_CHECK_MODULES(LIBWACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION]) | ||
+ PKG_CHECK_MODULES(WACOM, [gtk+-3.0, pango >= $PANGO_REQUIRED_VERSION]) | ||
+ PKG_CHECK_MODULES(WACOM_OLED, [gudev-1.0]) | ||
+ have_wacom=yes | ||
+ AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available]) | ||
+ ]) | ||
+ ], [ | ||
AC_MSG_ERROR([GUdev is necessary to compile Wacom support]) | ||
- fi | ||
- AC_DEFINE_UNQUOTED(HAVE_WACOM, 1, [Define to 1 if wacom support is available]) | ||
- have_wacom=yes | ||
+ ]) | ||
fi | ||
;; | ||
*) | ||
- have_wacom=no | ||
- ;; | ||
+ have_wacom=no | ||
+ ;; | ||
esac | ||
-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes) | ||
+AM_CONDITIONAL(BUILD_WACOM, test x$have_wacom = xyes) | ||
|
||
dnl --------------------------------------------------------------------------- | ||
dnl - common | ||
diff --git a/plugins/Makefile.am b/plugins/Makefile.am | ||
index 9324b406..ee78d6d0 100644 | ||
--- a/plugins/Makefile.am | ||
+++ b/plugins/Makefile.am | ||
@@ -4,7 +4,6 @@ enabled_plugins = \ | ||
a11y-keyboard \ | ||
a11y-settings \ | ||
clipboard \ | ||
- color \ | ||
datetime \ | ||
dummy \ | ||
power \ | ||
@@ -22,13 +21,19 @@ enabled_plugins = \ | ||
|
||
disabled_plugins = $(NULL) | ||
|
||
+if BUILD_COLOR | ||
+enabled_plugins += color | ||
+else | ||
+disabled_plugins += color | ||
+endif | ||
+ | ||
if SMARTCARD_SUPPORT | ||
enabled_plugins += smartcard | ||
else | ||
disabled_plugins += smartcard | ||
endif | ||
|
||
-if HAVE_WACOM | ||
+if BUILD_WACOM | ||
enabled_plugins += wacom | ||
else | ||
disabled_plugins += wacom | ||
diff --git a/plugins/dummy/Makefile.am b/plugins/dummy/Makefile.am | ||
index cb5856cf..06ac595a 100644 | ||
--- a/plugins/dummy/Makefile.am | ||
+++ b/plugins/dummy/Makefile.am | ||
@@ -22,10 +22,13 @@ gsd_dummy_LDADD = $(DUMMY_LIBS) $(top_builddir)/gnome-settings-daemon/libgsd.la | ||
desktopdir = $(sysconfdir)/xdg/autostart | ||
|
||
desktop_DATA = | ||
+if !BUILD_COLOR | ||
+desktop_DATA += org.gnome.SettingsDaemon.Color.desktop | ||
+endif | ||
if !SMARTCARD_SUPPORT | ||
desktop_DATA += org.gnome.SettingsDaemon.Smartcard.desktop | ||
endif | ||
-if !HAVE_WACOM | ||
+if !BUILD_WACOM | ||
desktop_DATA += org.gnome.SettingsDaemon.Wacom.desktop | ||
endif | ||
if !BUILD_PRINT_NOTIFICATIONS | ||
-- | ||
2.11.1 | ||
|
151 changes: 151 additions & 0 deletions
151
gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.23.90.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,151 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
|
||
inherit autotools eutils gnome2 python-any-r1 systemd udev virtualx | ||
|
||
DESCRIPTION="Gnome Settings Daemon" | ||
HOMEPAGE="https://git.gnome.org/browse/gnome-settings-daemon" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="+colord +cups debug input_devices_wacom -openrc-force networkmanager policykit smartcard test +udev wayland" | ||
REQUIRED_USE=" | ||
input_devices_wacom? ( udev ) | ||
smartcard? ( udev ) | ||
" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.44.0:2[dbus] | ||
>=x11-libs/gtk+-3.15.3:3 | ||
>=gnome-base/gnome-desktop-3.11.1:3= | ||
>=gnome-base/gsettings-desktop-schemas-3.23.3 | ||
>=gnome-base/librsvg-2.36.2:2 | ||
media-fonts/cantarell | ||
media-libs/alsa-lib | ||
media-libs/fontconfig | ||
media-libs/libcanberra[gtk3] | ||
>=media-sound/pulseaudio-2 | ||
>=sys-power/upower-0.99:= | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/libnotify-0.7.3:= | ||
x11-libs/libX11 | ||
x11-libs/libxkbfile | ||
x11-libs/libXi | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXtst | ||
x11-libs/libXxf86misc | ||
x11-misc/xkeyboard-config | ||
>=app-misc/geoclue-2.3.1:2.0 | ||
>=dev-libs/libgweather-3.9.5:2= | ||
>=sci-geosciences/geocode-glib-3.10 | ||
>=sys-auth/polkit-0.103 | ||
colord? ( | ||
>=media-libs/lcms-2.2:2 | ||
>=x11-misc/colord-1.0.2:= ) | ||
cups? ( >=net-print/cups-1.4[dbus] ) | ||
input_devices_wacom? ( | ||
>=dev-libs/libwacom-0.7 | ||
>=x11-libs/pango-1.20 | ||
x11-drivers/xf86-input-wacom | ||
virtual/libgudev:= ) | ||
networkmanager? ( >=net-misc/networkmanager-1.0 ) | ||
smartcard? ( >=dev-libs/nss-3.11.2 ) | ||
udev? ( virtual/libgudev:= ) | ||
wayland? ( dev-libs/wayland ) | ||
" | ||
# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly | ||
# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x | ||
# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x | ||
# systemd needed for power and session management, bug #464944 | ||
RDEPEND="${COMMON_DEPEND} | ||
gnome-base/dconf | ||
!openrc-force? ( sys-apps/systemd ) | ||
!<gnome-base/gnome-control-center-2.22 | ||
!<gnome-extra/gnome-color-manager-3.1.1 | ||
!<gnome-extra/gnome-power-manager-3.1.3 | ||
!<gnome-base/gnome-session-3.23.2 | ||
" | ||
# xproto-7.0.15 needed for power plugin | ||
# FIXME: tests require dbus-mock | ||
DEPEND="${COMMON_DEPEND} | ||
cups? ( sys-apps/sed ) | ||
test? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]') | ||
gnome-base/gnome-session ) | ||
app-text/docbook-xsl-stylesheets | ||
dev-libs/libxml2:2 | ||
dev-libs/libxslt | ||
sys-devel/gettext | ||
>=dev-util/intltool-0.40 | ||
virtual/pkgconfig | ||
x11-proto/inputproto | ||
x11-proto/xf86miscproto | ||
>=x11-proto/xproto-7.0.15 | ||
" | ||
|
||
python_check_deps() { | ||
use test && has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use test && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
# Make colord and wacom optional; requires eautoreconf | ||
eapply "${FILESDIR}"/${P}-optional.patch | ||
|
||
eautoreconf | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
--enable-man \ | ||
$(use_enable colord color) \ | ||
$(use_enable cups) \ | ||
$(use_enable debug) \ | ||
$(use_enable debug more-warnings) \ | ||
$(use_enable networkmanager network-manager) \ | ||
$(use_enable smartcard smartcard-support) \ | ||
$(use_enable udev gudev) \ | ||
$(use_enable input_devices_wacom wacom) \ | ||
$(use_enable wayland) | ||
} | ||
|
||
src_test() { | ||
virtx emake check | ||
} | ||
|
||
src_install() { | ||
gnome2_src_install udevrulesdir="$(get_udevdir)"/rules.d #509484 | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
|
||
if ! systemd_is_booted; then | ||
ewarn "${PN} needs Systemd to be *running* for working" | ||
ewarn "properly. Please follow the this guide to migrate:" | ||
ewarn "https://wiki.gentoo.org/wiki/Systemd" | ||
fi | ||
|
||
if use openrc-force; then | ||
ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement," | ||
ewarn "this can lead to unexpected problems and is not supported neither by" | ||
ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem," | ||
ewarn "you will need to disable this USE flag system wide and retest before" | ||
ewarn "opening any bug report." | ||
fi | ||
} |