Skip to content

Commit

Permalink
app-shells/peco: version bump to 0.5.10, fix #844379 (EGO_SUM)
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/844379
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Vladimir Pavljuchenkov <[email protected]>
Closes: gentoo#26943
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SpiderX authored and juippis committed Sep 5, 2022
1 parent 7628264 commit 5f4635a
Show file tree
Hide file tree
Showing 3 changed files with 68 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-shells/peco/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -16,4 +16,6 @@ DIST github.com%2Fpmezard%2Fgo-difflib%2F@v%2Fv1.0.0.mod 37 BLAKE2B 94636062c94f
DIST github.com%2Fpmezard%2Fgo-difflib%2F@v%2Fv1.0.0.zip 12433 BLAKE2B 0c911c9d173080abd8edbbab1f47222343801d8eeae36b4add24773e3282fc2a39283fdf519a3d4483e39cdb7d9509b8570d151f46841ac1a616f312dc4cb0ba SHA512 3b85697185ba85cdef6202444ab6cabeabfad8a03d66b3839a852586b1f91ddae7897a57c8c138d5647022aa44906c7ef3c5339d520f90eeea0742a935da8cf2
DIST github.com%2Fstretchr%2Ftestify%2F@v%2Fv0.0.0-20161117074351-18a02ba4a312.mod 35 BLAKE2B 0357260904c9ba41892132c7e07d2add9b10ce4a09e8db4966219d1f515f917581e2afa0987094c90759634bc2aeb66e758074e023ff331a8337f5090c0102f6 SHA512 5b7ce867497852e4918b8cde5f75ecf2f24b9c95ad112478ac132322e904243f1cea3d16f5731646efb669256dbefc129ac70a499c8b1d25403a14c7e4fad10b
DIST github.com%2Fstretchr%2Ftestify%2F@v%2Fv0.0.0-20161117074351-18a02ba4a312.zip 64565 BLAKE2B 6df66d84239453907b8fba81f24e2f54c0454bc2a4bb2ca574c9392edfc4910dfaa6ccb5151b9af3979249c78f79d501979f97d87fd40aacbe9152a38c19672a SHA512 e5fd6044defe077fd53a7e8b4258b134d58ea1299d8698c61ed5e6de51ca437300cca0a3b4a8eb1d39b5cb04d039bff769dc63ca73d3f016cfdae8e9e3963c0e
DIST peco-0.5.10-deps.tar.xz 443632 BLAKE2B 8ee92f51fd4156a518a9e020dacaf8e0489be228aa531b2c8565599b82b4a853a6bbd3543a353764b2917a7732541a02f256a2164dc828665189fbcc94ae2d75 SHA512 6358241a1f9f2926d9ce57f52646ef0e9e99c554b4d7a4708f6d3f29674f936a3f7519fb556794558923f8c7673d58878638c64a19aa00951104e7014e546159
DIST peco-0.5.10.gh.tar.gz 81697 BLAKE2B 927039707f36bb285aefccecbf1643d2728f7e90deb2f46793ff2d0b1c60d6d71a0d89c13132d6e8901257ca1b726cee36b64e6160230b5aa6e5b84e22f25c3d SHA512 6764ca67cce6f17b2386b8ccd00cbe2f90bbf2c813047a83436db0bb7bab52b889e28b25df7165e7c84dd968ff2fd98cd7d86d8cb4330262c67a0c01d78ff9ba
DIST peco-0.5.8.tar.gz 79589 BLAKE2B 04ae33b276686fb227de348a0ad4843a9ef15a3ef3ec051f82cf5a2955099a7092c4eb598cb718eac0092799f552066a32d4ca7773c0d1cf9a46b08ae115593a SHA512 7ab831a55eecd2091637da6e9044f2dce188b29748d5ccf2ff81ceff49c5013dd7cba52137ada3ad9aa779955197f7963cb7261f0d9551ddd13c5a0f5c8f835b
30 changes: 30 additions & 0 deletions app-shells/peco/peco-0.5.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

DESCRIPTION="Simplistic interactive filtering tool"
HOMEPAGE="https://github.com/peco/peco"
SRC_URI="https://github.com/peco/peco/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
https://github.com/SpiderX/portage-overlay/raw/deps/${P}-deps.tar.xz"

LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64"

DOCS=( {Changes,README.md} )

src_compile() {
ego build ./cmd/...
}

src_test() {
ego test ./...
}

src_install() {
einstalldocs
dobin peco
}
36 changes: 36 additions & 0 deletions app-shells/peco/peco-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

EGIT_REPO_URI="https://github.com/peco/${PN}.git"

inherit git-r3 go-module

DESCRIPTION="Simplistic interactive filtering tool"
HOMEPAGE="https://github.com/peco/peco"
SRC_URI=""

LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS=""

DOCS=( {Changes,README.md} )

src_unpack() {
git-r3_src_unpack
go-module_live_vendor
}

src_compile() {
ego build ./cmd/...
}

src_test() {
ego test ./...
}

src_install() {
einstalldocs
dobin peco
}

0 comments on commit 5f4635a

Please sign in to comment.