forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/dvdstyler: Bump to 3.0.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
74 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST DVDStyler-2.9.6.tar.bz2 8373340 SHA256 d9ac1c2fa8812c194d4a79a5954f96919a4823498a4200018964df549270c6e3 SHA512 7e45a61ecc5df29957c6ff71bf7d5032bc1cba3b43b8444f7cd065aabf3991961f998e220d41c05c3d4e9a3bc213c96bc484b467a40d1b10ab33630ea4cbbcea WHIRLPOOL d7b6f714fcde76c74f5f4dee66918ddfb17066f85147a7efd355fe19d057d3c56bf0f1116595cfa361b09f1d82ebc09ab0fad6f5fc8ab029df01a9abe267b564 | ||
DIST DVDStyler-3.0.2.tar.bz2 8818276 SHA256 fda2105c83c7bf31492573cc81a3ae8730bbab804286dad4d86b5e0bd053158e SHA512 2ae54a3679bea0a6ea6b98c6bd26af13b9e2cb938dd58cf263e2ca2999d5ad48b58598d6f6a4a230e1ca1988cf6095c5ce17c1c2d8c103e28238ddedc5ead006 WHIRLPOOL e9f9a587368a02c17a8166025dc1e1484f91a709a77f6a56e61fc8b5e70bcada4a0ae63037dbd9a89817bbb46eda6bf75a305913731d424f07d146507cda8045 | ||
DIST DVDStyler-3.0.3.tar.bz2 8850630 SHA256 1880386090723271688c236762b3dea5ae46422910a5f1ed68baf2faf51483c8 SHA512 b5e5a93d127bc45b844cadce036b2d70ede5b3ea9d5fd026a93d6a6813684873db41ca0d4cd15680e63a63f2ba4314f65c2a0c08e44d0b4bbcce703874c2c3ed WHIRLPOOL fb18ecdc865180ca06b545e07c962193a952414808b1ca8864744408c4615e307d0dc7adcd1a3f315916279deb67c1c5061537d5601c40a1f7b0e75ff2038079 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
MY_P=${P/dvds/DVDS} | ||
WX_GTK_VER=3.0 | ||
|
||
inherit wxwidgets eutils | ||
|
||
DESCRIPTION="A cross-platform free DVD authoring application" | ||
HOMEPAGE="http://www.dvdstyler.org/" | ||
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug libav +udev" | ||
|
||
COMMON_DEPEND=" | ||
>=app-cdr/dvd+rw-tools-7.1 | ||
media-libs/libexif:= | ||
>=media-libs/wxsvg-1.5.11:= | ||
>=media-video/dvdauthor-0.7.1 | ||
>=media-video/xine-ui-0.99.7 | ||
virtual/cdrtools | ||
libav? ( >=media-video/libav-9:0=[encode] ) | ||
!libav? ( >=media-video/ffmpeg-2.6:0=[encode] ) | ||
virtual/jpeg:0 | ||
x11-libs/wxGTK:${WX_GTK_VER}=[gstreamer,X] | ||
sys-apps/dbus | ||
udev? ( >=virtual/libudev-215:= ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=app-cdr/dvdisaster-0.72.4 | ||
media-video/mjpegtools | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
app-arch/zip | ||
app-text/xmlto | ||
sys-devel/gettext | ||
virtual/yacc | ||
virtual/pkgconfig | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
src_prepare() { | ||
need-wxwidgets unicode | ||
# disable obsolete GNOME 2.x libraries wrt #508854 | ||
sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure || die | ||
# rmdir: failed to remove `tempfoobar': Directory not empty | ||
sed -i -e '/rmdir "$$t"/d' docs/Makefile.in || die | ||
# fix underlinking wrt #367863 | ||
sed -i -e 's:@LIBS@:& -ljpeg:' wxVillaLib/Makefile.in || die | ||
# silence desktop-file-validate QA check | ||
sed -i \ | ||
-e '/Icon/s:.png::' -e '/^Encoding/d' -e '/Categories/s:Application;::' \ | ||
data/dvdstyler.desktop || die | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--docdir=/usr/share/doc/${PF} \ | ||
$(use_enable debug) \ | ||
--with-wx-config=${WX_CONFIG} | ||
} | ||
|
||
src_install() { | ||
default | ||
rm -f "${ED}"/usr/share/doc/${PF}/{COPYING*,INSTALL*} | ||
} |