forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/whoosh: version bump to 2.7.3
Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST Whoosh-2.6.0.zip 1193541 SHA256 7de7bc4d00a6d051dbb360b48eb7f3cd002373d87252fb0b284a3c9c453a7677 SHA512 e50e47ec0d1c65ad3c7d657586f5380a1be748945c1ce964305fa68b99379f0da676faef6f0ca45ef151df7be71150601162ee966f3aaf84047a20bca36f7e37 WHIRLPOOL c42e9760833db7186f3df5946f6dd071288cfccf2eaefba95520a2415ca377c49cf74307b3fa2c9e655f134b086ae637e5db06330248b4a27e12175920f3c7b8 | ||
DIST Whoosh-2.7.0.zip 1080985 SHA256 733df1ad4142fcd1e8f3259070de0521d272d7685e2febc0f4fdd1668cfe0d48 SHA512 5126a9ed5ef50af391905347c7aa1c1cc7d100213c29f5a5f67fcfabab9cdcfcd14a6b75735df8e343f61254d1fec8610f0e1260167a321ab303a0a55b02673f WHIRLPOOL 6a35448280e3c6382b8a4b50432d5def3a910d9af95d35afc11544030b69f0103aae910bbf91cb5942ec80f10a848bbd32dbd828c71482f5e2fc15a9cd29c249 | ||
DIST Whoosh-2.7.2.zip 1096847 SHA256 0f72a49e02e2669a50f1ecaf0364fe0451619473c404efeca9914dd878de73f2 SHA512 3a5e41328e9bce102b9e68d648f6a0e61fa7e6be1585fd70a5885afb885717d0a4e73ef1b6d2086edec996228bbfbd6d7e01eaa64e831223ef1ea7b764d25d7f WHIRLPOOL eaaa85fd62e03bb63ac8cc48c9e29b2c9daf435e848aec7b7747e6fd390245bda044c5e9bafbf9e5f7df22b93e4cfacdc180cc821e3bd4739c229f6aaf9b58e0 | ||
DIST Whoosh-2.7.3.zip 1097515 SHA256 aa6db447522e208ae652c6ce063bb23cedec47f5ed630121b3debaa011fcb9c4 SHA512 3df18ed30f63aaa9f858d596919fa8a927f7203a52bdb4c584117b28bce313cbbb530cdb144e35af99763edbbc7d3f5c79680d04fa7c04efa91376ba62b6f556 WHIRLPOOL 1829fd083485367dd0751844c77e5f7e8c8edee4021b8518415ab6cd6f8db84b5f2f188d6e2128a105cfd8076d8101c1421838ac18f10cd632c64eed5828a44e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy ) | ||
|
||
MY_PN="Whoosh" | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library" | ||
HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.python.org/pypi/Whoosh/" | ||
SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip" | ||
|
||
DEPEND="app-arch/unzip | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc test" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
python_prepare_all() { | ||
# (backport from upstream) | ||
sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die | ||
|
||
# Prevent un-needed download during build | ||
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
# https://bitbucket.org/mchaput/whoosh/issue/403/ | ||
use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html | ||
} | ||
|
||
python_test() { | ||
# https://bitbucket.org/mchaput/whoosh/issue/412/tarball-of-whoosh-270-pypi-missing-english | ||
# tarball missing a file english-words.10.gz which when added sees all tests pass. | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
local DOCS=( README.txt ) | ||
use doc && local HTML_DOCS=( docs/source/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |