forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/gixy: Version bump to 0.1.8
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
32 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gixy-0.1.5.tar.gz 32594 SHA256 3607081531df4ee52758850632879796b9f294c93a8068022d044aa4f5a61423 SHA512 63c41a16f1a1d16664c660150bf1603b87d2a2b474db58bb13af79e123b372a666b94aa96ef081af89fb5608c7f9a43e03750afb80d52c212c06d3407c413e38 WHIRLPOOL 1a87ec527dd9014100d4e75ef69d3a981d37420acac7260ce82722bd5062d1c035142e0251cb2dfc125546decdae121e23451377846702264f0719948f6cc9ff | ||
DIST gixy-0.1.8.tar.gz 35176 SHA256 65a4702bee221d1c86ddace10a04f48dc036d1658c28fbbcf533357d4f9d7d25 SHA512 fe45522dbee238282f05f11fc22bdff6f04df117d9b909aa3a9c7ff0aef3c376e65119e91e8e562a2ea5d9c2e85a1e43462eb3ce14f30c171235bd44097c7a94 WHIRLPOOL f3a0471435a31f681aca1867a5d6c1b8dbb0d48893974e7e679d14568b72788ffaef462c780eaa8602756585243477aefefb8b44a584a08e62e7d3e06fdeec3e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_5,3_6} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Nginx configuration static analyzer" | ||
HOMEPAGE="https://github.com/yandex/gixy" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MPL-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}] | ||
>=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}] | ||
>=dev-python/jinja-2.8[${PYTHON_USEDEP}] | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.1.0[${PYTHON_USEDEP}]" | ||
|
||
DEPEND="${RDEPEND}" | ||
|
||
python_prepare() { | ||
sed -i -e "/argparse/d" setup.py || die | ||
distutils-r1_python_prepare_all | ||
} |