Skip to content

Commit

Permalink
net-libs/gsoap: Bump to version 2.8.37
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Oct 29, 2016
1 parent 24dac91 commit 6030b71
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/gsoap/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST gsoap_2.7.17.zip 10224444 SHA256 d3af1ce9464b28cacdf1dfbe09b689f8927cbcf394
DIST gsoap_2.8.23.zip 22482000 SHA256 e1c30743f1c2cf40b2760568127e14af1b2a00c3026b2e5f0750e8c33d94c061 SHA512 cc90aadfe09aa6406172c9ffa07696851ff594ca7c5b40819494badd8ce978d908d66de63a5831e7aec1bca18ee8b51ed02187057688a3b36eb0a21fe6e0f5a4 WHIRLPOOL e5cfc9c5758847d1fc94cbd38108b80c7548abc0316fe201b58604a3b22d30b9748c81d4aec13f53356593f3ddc2dcba14170a53d63795eab9229ec49d4bc585
DIST gsoap_2.8.35.zip 33403536 SHA256 629f2de1674285e8da76ad75c85bab421b07c51cb11560e614b3d9b87a6eb04f SHA512 33b2c75a6b9afcdfe5b9a98ba0f720ff4c36fb9073207bfbe1d1d128ef69f093eb58377521a0671b0bd9bfa02e169cad7e40c8c51cce69e22658067425cf1304 WHIRLPOOL cb8ee193b508a2e9b1cb6a5edaa40f0f642c81301d72a1e09c0655346ee8339b9c1d8e80feea3fe3ba0a204e471b1f4514c2cf44e015b95fc9e242d1b08ec7b1
DIST gsoap_2.8.36.zip 33403319 SHA256 20f70db768062e094ec3749073bfc4103cacaac8cab2cdbd624634ae496eef21 SHA512 6ebe479b91a1df92a7ac9019762d0a225f255ce9a772d56a50bccfe9b16645d1ee3bb38e4d2dd2fd960a3f9feee152204158e8002813db8d9ed6b2453c096287 WHIRLPOOL eef71f207e0b1665b50111f18245d1aea057464d198c0e448661503ceea17885d5d39b8030d1becfbc94598149559f9161c1e09bb764e0e8a5dc9176c3afb5fb
DIST gsoap_2.8.37.zip 33414035 SHA256 a3cb4807151b9a3f8e019a633e3109f5cb644a6178d8f51b7e2a38c71f2c6edb SHA512 b131e4fb45933566b1b35038a375daf9f13ec1e4f4a42fcfdfab12bab8190ca0c73a6e664c1723d23f81b8ebce01de153636f7cc9e19df167954cffb73a38199 WHIRLPOOL 93fff8ab2e73663974873bb5d193b77b40c58c0e4852fbd20552fc0c52173a698a8adf01a5687552acc13c16edd769f13007f742ef081a6948f1157ecebae73a
80 changes: 80 additions & 0 deletions net-libs/gsoap/gsoap-2.8.37.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils

MY_P="${PN}-2.8"

DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
HOMEPAGE="http://gsoap2.sourceforge.net"
SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"

LICENSE="GPL-2 gSOAP"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc debug examples ipv6 libressl gnutls +ssl"

RDEPEND="
sys-libs/zlib
gnutls? ( net-libs/gnutls )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
)
"
DEPEND="${RDEPEND}
app-arch/unzip
sys-devel/flex
sys-devel/bison
"

S="${WORKDIR}/${MY_P}"

src_prepare() {
default

# Fix Pre-ISO headers
eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"

eautoreconf
}

src_configure() {
local myconf=()
use ssl || myconf+=( --disable-ssl )
use gnutls && myconf+=( --enable-gnutls )
use ipv6 && myconf+=( --enable-ipv6 )
econf \
${myconf[@]} \
$(use_enable debug) \
$(use_enable examples samples)
}

src_compile() {
emake -j1
}

src_install() {
emake DESTDIR="${D}" install

# yes, we also install the license-file since
# it contains info about how to apply the licenses
dodoc *.txt

dohtml changelog.md

prune_libtool_files --all

if use examples; then
rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
insinto /usr/share/doc/${PF}/examples
doins -r gsoap/samples/*
fi

if use doc; then
dohtml -r gsoap/doc/*
fi
}

0 comments on commit 6030b71

Please sign in to comment.