Skip to content

Commit

Permalink
app-office/projectlibre-bin: New package to supersede openproj
Browse files Browse the repository at this point in the history
Gentoo-Bug: 436958

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Chris Reffett committed Jan 8, 2017
1 parent 6c847f6 commit 604dbcb
Show file tree
Hide file tree
Showing 5 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/projectlibre-bin/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST projectlibre-1.6.2.tar.gz 14735171 SHA256 72ea964533a2da0af0882acb91268647e7f5a99151b0abb8f3b84c6f26229fc4 SHA512 128319a37aeeb4603fd45433e3961805b0de30e5760394d5eef2de1910bff3815e600462aa3264fa64df55eb8568849895c9d673e5574badafcbc1df89e2c9e7 WHIRLPOOL 78124a7a2dd488b55938cd0e2465ab5212dd3cc9dfb673a408664667fe49458ac6cf8aa9b684832e51c1af18f7fdd48acd5fd967db70eb4ee5f9f3b70c615289
12 changes: 12 additions & 0 deletions app-office/projectlibre-bin/files/projectlibre.desktop
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
[Desktop Entry]
Encoding=UTF-8
Name=ProjectLibre
Comment=Project Management
Comment[fr]=Gestion de projet
Exec=projectlibre %F
Icon=projectlibre
Terminal=false
Type=Application
Categories=Office;ProjectManagement;
MimeType=application/x-projectlibre;

Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
11 changes: 11 additions & 0 deletions app-office/projectlibre-bin/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Chris Reffett</name>
</maintainer>
<upstream>
<remote-id type="sourceforge">projectlibre</remote-id>
</upstream>
</pkgmetadata>
51 changes: 51 additions & 0 deletions app-office/projectlibre-bin/projectlibre-bin-1.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=6

inherit eutils

MY_PN=${PN/-bin}
MY_P="${MY_PN}-${PV}"

DESCRIPTION="An open source desktop alternative to Microsoft Project"
HOMEPAGE="http://www.projectlibre.org/"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"

LICENSE="CPAL-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=virtual/jre-1.8"
DEPEND=""

S=${WORKDIR}/${MY_P}

src_unpack() {
unpack ${MY_P}.tar.gz
cp "${FILESDIR}"/${MY_PN}.{desktop,png} ./ || die
cd "${S}"
rm -rf license projectlibre.bat
}

src_prepare() {
eapply_user
sed -i \
-e "/^OPENPROJ_HOME0=/s:=.*:=/opt/${MY_PN}:" \
${MY_PN}.sh || die
}

src_install() {
local d="/opt/${MY_PN}"
insinto ${d}
doins -r * || die
fperms a+rx ${d}/${MY_PN}.sh

dodir /opt/bin
dosym ../${MY_PN}/${MY_PN}.sh /opt/bin/${MY_PN} || die

newmenu ../${MY_PN}.desktop ${MY_PN}.desktop || die
newicon ../${MY_PN}.png ${MY_PN}.png || die
}

0 comments on commit 604dbcb

Please sign in to comment.