Skip to content

Commit

Permalink
dev-ruby/rack: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
graaff committed Aug 24, 2015
1 parent 4b7a08a commit 60742ad
Show file tree
Hide file tree
Showing 3 changed files with 87 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-ruby/rack/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
DIST rack-1.4.6.gem 204800 SHA256 f65ad9022e83e6517d6e3e37cecb781cd172061e769068334bab142d3435f13d SHA512 c4b9ab76f16079d26a045811305a62f882230058fdcbc157e176d85db9c5cfb3e7e672cbd68136339a986bd643bf202307f7db51f4f1313ecf47a750254a13f3 WHIRLPOOL 859b0da71b162d153ae775830c220bceda0fe556582235adec8e28105157be743ec94f61673cdb517a5683543d976b517087c3f1fbd5a5b4977754d423e9c3fb
DIST rack-1.4.7.gem 204800 SHA256 fa06e970605808834fc7e5a8b9babd4871d7d4c23a4d9d61cb94cbd4c15de5e6 SHA512 26391faec30b12981413eb1f433bfc9be5d124689bc3ae6e32de7d544917f2330fa4f9255c6879632f2edae5a05a4198454b8fe1310bcdb3d2e0b8b336a20359 WHIRLPOOL 3e20db05b829b8dadbcc9dbeff6e883cdf1a8b175bd0af0f9c511ab2dc1111036b5815abe8c342120b74a0727a79b18b5966ec90d073404489b2045b134c527a
DIST rack-1.5.4.gem 216064 SHA256 401f8725be81ca60a4c8366fca674a9f18e9bc577b6ad4f42c9f66d763107e6e SHA512 713c3815ff4d6c1f498b9d3081b1f1a8ea929712fa6fb045fafe8544552b9d9db448e5a9862a6d40c1a1769788538630b5142daec157efc0e19dc0490d74e638 WHIRLPOOL 6313b68b1852a7d464bf18d3564c5978482fcb344086f6d404dce2fa6d8ccfd4c32b69e6eca59eeb2c32481e8f5910d21af2ba9b7f4baf193e72c160f8925de4
DIST rack-1.5.5.gem 216576 SHA256 4ae4a74f555008ecc541060515c37baa9e16f131538447a668c0bf52117c43b7 SHA512 7b8ea669c55fa94801aae20612076db702837194bc602c64bec1085836712806a081504b37e4c545bcccf0337e7afc0ad9dca3c1258260fde5f3ec505247056a WHIRLPOOL 3eed7d4befb678d1b89f2dd8f03b119ab23f6155c9fdc55d545a02a23fd718d436ca5ff880bec1a17ee7927183aed1d298cef97c1737cf88a315161a2f4ab37e
DIST rack-1.6.2.gem 227840 SHA256 89278d4842d0ecdd1e79cbf7a894dc86f976e6d25debc6814343298fd19ed017 SHA512 0f0cdd2e55bb03ea73ab6ba339ca6027b2072425323b685b3f71c0b739276ad8009ec7f00b0f3f87c07229ccb70325473d2ec03a1f82a3ddc6e6d9f5545948ff WHIRLPOOL 4897e9d2b6fadd090375a899d93a95f33269db02c1d5f78816deccc3fb4b3684b89409a106306e117412757c50643b6ecd574c89c1d7951d866f20f33b9598fd
DIST rack-1.6.4.gem 228864 SHA256 455ec4545a54b40dae9937bc5f61ee0e32134191cc1ef9a7959a19ec4b127a25 SHA512 304a6ae21bfd38008fd7d147f82c44397f3a1d2e689bd01de689aedc6ea0e8784605207fd314bc796974edc5dfcab81636664ea2becb0489302999f99501d41a WHIRLPOOL e99b545a783eaf09bc1c0cf3b4abfafa3341980cfebf1840e25ab25d5801d911da7dfbb232f70df291b7494cc8f8c089fe8a654502aa808850801c02b1e481c6
43 changes: 43 additions & 0 deletions dev-ruby/rack/rack-1.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="http://rack.github.com/"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.4.5-fix-test-ruby20.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all. We do add the fcgi dependency because
# that spec isn't optional.
ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6-r1:1.3"

each_ruby_test() {
# Since the Rakefile calls specrb directly rather than loading it, we
# cannot use it to launch the tests or only the currently-selected
# RUBY interpreter will be tested.
${RUBY} -S bacon -Ilib -w -a \
-q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
|| die "test failed for ${RUBY}"
}
42 changes: 42 additions & 0 deletions dev-ruby/rack/rack-1.5.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="http://rack.github.com/"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.
ruby_add_bdepend "test? ( dev-ruby/bacon )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"

each_ruby_test() {
# Since the Rakefile calls specrb directly rather than loading it, we
# cannot use it to launch the tests or only the currently-selected
# RUBY interpreter will be tested.
${RUBY} -S bacon -Ilib -w -a \
-q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
|| die "test failed for ${RUBY}"
}

0 comments on commit 60742ad

Please sign in to comment.