Skip to content

Commit

Permalink
app-xemacs/ebuild-mode: add 1.69
Browse files Browse the repository at this point in the history
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Nov 5, 2023
1 parent 6b5860a commit 608feea
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-xemacs/ebuild-mode/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.67.tar.xz 40332 BLAKE2B 545106fbf63737015c8b80b715708c430dafc83484bd2d27901c1e81b5ecb10a0494a0f8ab9e0d3243f62c57045c1571ea75fd6813cbd74a04e507a2dadc3b3a SHA512 672c23ae77de6784a43329607b05f3ff354f0271a5051b886ede7b1d92a667f7968579a941b55e60839cbf0b79082e726aa32e1a81d3302acc84d866e3892a2b
DIST ebuild-mode-1.68.tar.xz 41060 BLAKE2B 2f4882778368b9d9e40579a661b294fef6c68a27072a7d983caa7d54338441a659c27edbeacf74b3aac870b056996c3bdca233352e7fd2a319c3c2649a49eb56 SHA512 b03d0adabd9804999317ac688763d28e2ef09539c5ac75faeeb758ac56e9015946440447a0301c98356897e1b6f19e3e2aec5aec647c0ee1ae868beda2347ddd
DIST ebuild-mode-1.69.tar.xz 41436 BLAKE2B 9c3a41e6dac89d1c3908f72dfd4f2c2f62a1337fa9de1318d26901ae51c5b17cec429839378fa8df155f65807bc16efb9235b1913d4a3704d0d79df9fddd7af6 SHA512 2ba94f268f74a8424fccfc7ffff3d0e008261224a389253f67be91b6ade0301600fd50c0bb4b5f0487acb5b0add68dd6895a03dd7b096095034d59bc300e8a53
44 changes: 44 additions & 0 deletions app-xemacs/ebuild-mode/ebuild-mode-1.69.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit optfeature

DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"

RDEPEND=">=app-editors/xemacs-21.4.20-r5
app-xemacs/sh-script"
BDEPEND="${RDEPEND}"

src_compile() {
local XEMACS="${EPREFIX}/usr/bin/xemacs"

"${XEMACS}" -batch -q --no-site-file \
-eval "(add-to-list 'load-path nil)" \
-f batch-byte-compile \
ebuild-mode.el gentoo-newsitem-mode.el || die

"${XEMACS}" -batch -q --no-site-file \
-eval "(setq autoload-package-name \"${PN}\")" \
-eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
-l autoload -f batch-update-autoloads \
ebuild-mode.el gentoo-newsitem-mode.el || die
}

src_install() {
insinto /usr/share/xemacs/site-packages/lisp/${PN}
doins *.el *.elc
}

pkg_postinst() {
optfeature "ebuild commands support" sys-apps/portage
optfeature "additional development tools" dev-util/pkgdev
optfeature "ebuild QA utilities" dev-util/pkgcheck
}

0 comments on commit 608feea

Please sign in to comment.