Skip to content

Commit

Permalink
www-client/qupzilla: 2.2.3 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
a17r committed Dec 25, 2017
1 parent c634bf2 commit 6099ad1
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/qupzilla/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST QupZilla-2.1.2.tar.xz 2767560 BLAKE2B 4d012f86618680a112c227d07d71c24d6fc2c517be63fe172abc99eb0c20e8b2756e2cc51049b0dff91e1739357121afe0b1e7328df372370dec969995447eb0 SHA512 d09a394ba70ae0f7f908940a26d6554a3706b6638c197d16b75e1e5855f76015c8e13b7155c40dacee3a38080a0c277d9410eaf07cf912dc4b295eafe1ff6343
DIST QupZilla-2.2.2.tar.xz 2499180 BLAKE2B 4fda216aa9698e7185ecae6229f511e77c152454c33208966a1def9726ff097cdb198ad368b23606f756985ad8a5fea85269ebc030b49e0d74c48ca53ab044b1 SHA512 15d5b8c9fa1fa88ca8af49527068258eaec49181c3acf2142a6fbc59057e2f2765733fe51bc283bd7ce52c9815520ad5bc5185b5ee284b13139ab9706ea188b3
DIST QupZilla-2.2.3.tar.xz 2498680 BLAKE2B 277134a8cf7efd6566d1be222ad541951fa92606926cdf10266c74b0c4ff9af0ba641accb26ac4759fe6d3083511201229f9c0ebd7042dc38028b79149571abd SHA512 5c9e7c029f2522693bf834ef4ade0e26ce950c900405404ba027c3c61e72aaeba7dc4710840844871553c343d403dac7562d3a95aba0d850f4576edde7b9cc3d
DIST qupzilla-plugins-2016.05.02.tar.gz 425314 BLAKE2B c10f9f3fe17f36b91a77b4bdb15b3d0c63160c50b558ba2f180ec83b2d226b15baea51e9125e0c72d3960c2f99f8f3753d90c7eeb4b88eb07381da19bc3ea777 SHA512 b294ecb2372b3267603a43bc7412ab75d2cd29a8c4667331f0d2c74e3b0b99d0c2a005b9e4854c6d777894522bba9fb3b1607e85e8da6dcbaa760c9ddc6288f2
DIST qupzilla-plugins-2017.03.26.tar.gz 430926 BLAKE2B d5db8c854886b1af8db20aaffe9a244600259d4f8cbc40890bf0f1075f790afe1a6e2ac19abe06c585eff0353127a3a7b1b1b79013bfc1b81bf5df750e5d9d20 SHA512 3b04b41208dddd25fd58937986cf12f2b521cf78a64380b915d46735ada3f4776f914056c5511daa781c89867d0309af7cbf833eb71dfa4b14b6b9ba25d80315
115 changes: 115 additions & 0 deletions www-client/qupzilla/qupzilla-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PLOCALES="ar_SA bg_BG ca_ES cs_CZ da_DK de_DE el_GR es_419 es_ES es_MX es_VE
eu_ES fa_IR fi_FI fr_FR gl_ES he_IL hr_HR hu_HU id_ID is it_IT ja_JP
ka_GE lg lt lv_LV nb_NO nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK
sl_SI sr sr@ijekavian sr@ijekavianlatin sr@latin sv_SE tr_TR uk_UA
uz@Latn zh_CN zh_HK zh_TW"

PLUGINS_HASH="80fea7df7765fdf9c9c64fdb667052b25f1c0a22"
PLUGINS_VERSION="2017.03.26" # if there are no updates, we can use the older archive

inherit l10n qmake-utils xdg-utils

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/QupZilla/${PN}.git"
else
MY_P=QupZilla-${PV}
SRC_URI="https://github.com/QupZilla/${PN}/releases/download/v${PV}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
S=${WORKDIR}/${MY_P}
fi

DESCRIPTION="A cross-platform web browser using QtWebEngine"
HOMEPAGE="https://www.qupzilla.com/"
SRC_URI+=" https://github.com/QupZilla/${PN}-plugins/archive/${PLUGINS_HASH}.tar.gz -> ${PN}-plugins-${PLUGINS_VERSION}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
IUSE="dbus debug gnome-keyring kwallet libressl nonblockdialogs"

RDEPEND="
>=dev-qt/qtcore-5.8:5
>=dev-qt/qtdeclarative-5.8:5[widgets]
>=dev-qt/qtgui-5.8:5
>=dev-qt/qtnetwork-5.8:5[ssl]
>=dev-qt/qtprintsupport-5.8:5
>=dev-qt/qtsql-5.8:5[sqlite]
>=dev-qt/qtwebchannel-5.8:5
>=dev-qt/qtwebengine-5.8:5[widgets]
>=dev-qt/qtwidgets-5.8:5
>=dev-qt/qtx11extras-5.8:5
x11-libs/libxcb:=
dbus? ( >=dev-qt/qtdbus-5.8:5 )
gnome-keyring? ( gnome-base/gnome-keyring )
kwallet? ( kde-frameworks/kwallet:5 )
libressl? ( dev-libs/libressl:= )
!libressl? ( dev-libs/openssl:0= )
"
DEPEND="${RDEPEND}
>=dev-qt/linguist-tools-5.8:5
>=dev-qt/qtconcurrent-5.8:5
virtual/pkgconfig
"

DOCS=( AUTHORS BUILDING.md CHANGELOG FAQ README.md )

src_unpack() {
if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
fi
default
}

src_prepare() {
# get extra plugins into qupzilla build tree
mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_HASH}/plugins/* src/plugins/ || die

rm_loc() {
# remove localizations the user has not specified
sed -i -e "/${1}.ts/d" translations/translations.pri || die
rm translations/${1}.ts || die
}

# remove outdated prebuilt localizations
rm -rf bin/locale || die

# remove empty locale
rm translations/empty.ts || die

l10n_find_plocales_changes translations '' .ts
l10n_for_each_disabled_locale_do rm_loc

default
}

src_configure() {
# see BUILDING document for explanation of options
export \
QUPZILLA_PREFIX="${EPREFIX}/usr" \
USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
DEBUG_BUILD=$(usex debug true '') \
DISABLE_DBUS=$(usex dbus '' true) \
GNOME_INTEGRATION=$(usex gnome-keyring true '') \
KDE_INTEGRATION=$(usex kwallet true '') \
NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs true '')

eqmake5
}

src_install() {
emake INSTALL_ROOT="${D}" install
einstalldocs
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit 6099ad1

Please sign in to comment.