forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.3
- Loading branch information
Showing
5 changed files
with
169 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST smb4k-1.2.1.tar.xz 3817104 SHA256 6562ab12c783d47e246d9d0a43b2342288384a7a78e0207a14e1dd6c40ffe97b SHA512 df5782de9b140dc6ec97f4b66e758dc62923a6d6e85843717a0a17b3f853d036bcd3e73cf289819c5b5caa6bc28e3943dea73a745197356a3351d5a643c21f37 WHIRLPOOL 6e89a20d4a7ce48278db2a27c7ce291c737f6a6485a02febedb4fc45dedadff2185867e87ad14d97cb1e56a593c80d7b09b2a1ee65c5a4dae0784700772f100b | ||
DIST smb4k-1.2.2.tar.xz 3938932 SHA256 338b43e9be4e0d8263329f145331656ff7d134e0038c3e830fb8a7b57f3cb5f6 SHA512 78cb5a3226d15d4b3f0eaa02cfe2969f18497f0ad3b6447338988f38540b3835fcea7acf05a50fd5d2b2c6a0873e341d099242e00c5660cbfd2e9795fcf3790e WHIRLPOOL b36ab80b8785c42dbff4593cbbad33d7be08a86c03be1d4349bf37da3b5cf15a3b9b041d7ea62eaf31ae5a03b054d72e745c448e35d1ae59ee53abad38807332 | ||
DIST smb4k-1.9.90.tar.xz 3594360 SHA256 0ade199d85ce281bb98b7618ac8d7b66c7958c16619448c2f5277a8a315cb734 SHA512 1b412534299fec80f38936538accb045fa4754a9ad0a73e045b7f12abc6996332f9ef9be1572db791ebff67c4d5ee3b70aad83932665fd7def2cff57ea4f5260 WHIRLPOOL f7a8929fc3d7c840f1adf717f94a7a6f2df7b4a938605395e85f28419d210f5d1e9200cbc9d4b061fde630fc20f0fdc9c0cce39293f7919f8f55c31e74ea9d82 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,82 @@ | ||
commit 8ea13011bbb0fcf232c1cdd5f7763ab2ac1e7455 | ||
Author: Andreas Sturmlechner <[email protected]> | ||
Date: Tue Feb 7 01:13:39 2017 +0100 | ||
|
||
Consolidate {KF5,QT5}_MIN_VERSION, mark KF5Plasma as RUNTIME dep | ||
|
||
In addition, sort and cleanup deps | ||
|
||
REVIEW: 129930 | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index b053562..39c45e6 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -19,36 +19,40 @@ include(KDECMakeSettings) | ||
include(FeatureSummary) | ||
include(ECMInstallIcons) | ||
|
||
+set(QT_MIN_VERSION "5.4.0") | ||
+set(KF5_MIN_VERSION "5.9.0") | ||
+ | ||
# Qt5 modules | ||
-find_package(Qt5Core 5.4.0 REQUIRED) | ||
-find_package(Qt5Gui 5.4.0 REQUIRED) | ||
-find_package(Qt5Widgets 5.4.0 REQUIRED) | ||
-find_package(Qt5Qml 5.4.0 REQUIRED) | ||
-find_package(Qt5Test 5.4.0 REQUIRED) | ||
-find_package(Qt5Network 5.4.0 REQUIRED) | ||
-find_package(Qt5PrintSupport 5.4.0 REQUIRED) | ||
+find_package(Qt5Core ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5Gui ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5Network ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5PrintSupport ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5Qml ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5Test ${QT_MIN_VERSION} REQUIRED) | ||
+find_package(Qt5Widgets ${QT_MIN_VERSION} REQUIRED) | ||
|
||
# KF5 modules | ||
-find_package(KF5Config 5.9.0 REQUIRED) | ||
-find_package(KF5Auth 5.9.0 REQUIRED) | ||
-find_package(KF5DocTools 5.9.0 REQUIRED) | ||
-find_package(KF5IconThemes 5.9.0 REQUIRED) | ||
-find_package(KF5WidgetsAddons 5.9.0 REQUIRED) | ||
-find_package(KF5I18n 5.9.0 REQUIRED) | ||
-find_package(KF5Completion 5.9.0 REQUIRED) | ||
-find_package(KF5CoreAddons 5.9.0 REQUIRED) | ||
-find_package(KF5Solid 5.9.0 REQUIRED) | ||
-find_package(KF5KIO 5.9.0 REQUIRED) | ||
-find_package(KF5Notifications 5.9.0 REQUIRED) | ||
-find_package(KF5XmlGui 5.9.0 REQUIRED) | ||
-find_package(KF5JobWidgets 5.9.0 REQUIRED) | ||
-find_package(KF5Wallet 5.9.0 REQUIRED) | ||
-find_package(KF5DBusAddons 5.9.0 REQUIRED) | ||
-find_package(KF5Parts 5.9.0 REQUIRED) | ||
-find_package(KF5ConfigWidgets 5.9.0 REQUIRED) | ||
-find_package(KF5Notifications 5.9.0 REQUIRED) | ||
-find_package(KF5WindowSystem 5.9.0 REQUIRED) | ||
-find_package(KF5Plasma 5.9.0 REQUIRED) | ||
+find_package(KF5Auth ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Completion ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Config ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5ConfigWidgets ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5CoreAddons ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5DBusAddons ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5DocTools ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5I18n ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5IconThemes ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5JobWidgets ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5KIO ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Notifications ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Parts ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Solid ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5Wallet ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5WidgetsAddons ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5WindowSystem ${KF5_MIN_VERSION} REQUIRED) | ||
+find_package(KF5XmlGui ${KF5_MIN_VERSION} REQUIRED) | ||
+ | ||
+find_package(KF5Plasma ${KF5_MIN_VERSION}) | ||
+set_package_properties(KF5Plasma PROPERTIES TYPE RUNTIME) | ||
|
||
# Make sure that Smb4K builds when several custom targets | ||
# with the same name exist (happens in the po directory). |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
commit 5da742c6fcaf9f15d4dc5dfba62ec42b59cbfcce | ||
Author: Andreas Sturmlechner <[email protected]> | ||
Date: Tue Feb 7 01:49:45 2017 +0100 | ||
|
||
Add ki18n_install and kdoctools_install calls for release tarball | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index b053562..d9df8ec 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -70,6 +70,13 @@ add_subdirectory(smb4k) | ||
add_subdirectory(data) | ||
add_subdirectory(doc) | ||
|
||
+if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/po") | ||
+ ki18n_install(po) | ||
+ if(KF5DocTools_FOUND) | ||
+ kdoctools_install(po) | ||
+ endif(KF5DocTools_FOUND) | ||
+endif(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/po") | ||
+ | ||
########### Plasmoid #################### | ||
|
||
# option(INSTALL_PLASMOID "Install plasmoid" ON) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/CMakeLists.txt 2017-02-05 20:23:51.000000000 +0100 | ||
+++ b/CMakeLists.txt 2017-02-07 01:55:44.766375980 +0100 | ||
@@ -94,7 +94,3 @@ | ||
########### install files ############### | ||
|
||
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) | ||
-find_package(KF5I18n CONFIG REQUIRED) | ||
-ki18n_install(po) | ||
-find_package(KF5DocTools CONFIG REQUIRED) | ||
-kdoctools_install(po) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Advanced network neighborhood browser" | ||
HOMEPAGE="https://sourceforge.net/p/smb4k/home/Home/" | ||
[[ ${PV} != 9999 ]] && SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz" | ||
|
||
[[ ${PV} != 9999 ]] && KEYWORDS="~amd64 ~x86" | ||
LICENSE="GPL-2" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kauth) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep kwallet) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_frameworks_dep solid) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtprintsupport) | ||
$(add_qt_dep qttest) | ||
$(add_qt_dep qtwidgets) | ||
" | ||
RDEPEND="${DEPEND} | ||
$(add_frameworks_dep plasma) | ||
>=net-fs/samba-3.4.2[cups] | ||
!net-misc/smb4k:4 | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${P}-deps.patch | ||
"${FILESDIR}"/${P}-po{1,2}.patch | ||
) |