Skip to content

Commit

Permalink
games-rpg/zsxd: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.2
  • Loading branch information
austin987 committed Oct 28, 2016
1 parent db9e657 commit 60cc5cc
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 3 deletions.
59 changes: 59 additions & 0 deletions games-rpg/zsxd/zsxd-1.9.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils gnome2-utils cmake-utils

DESCRIPTION="A free 2D Zelda fangame parody"
HOMEPAGE="http://www.solarus-games.org/"
SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"

LICENSE="all-rights-reserved CC-BY-SA-3.0 GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="mirror bindist"

RDEPEND=">=games-engines/solarus-1.3.1-r1
<games-engines/solarus-1.4.0"
DEPEND="app-arch/zip"

DOCS=( ChangeLog readme.txt )

src_prepare() {
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DSOLARUS_INSTALL_DATAROOTDIR="/usr/share"
-DSOLARUS_INSTALL_BINDIR="/usr/bin"
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
newicon -s 256 build/icons/${PN}_icon_256.png ${PN}.png

# install proper wrapper script
rm -f "${ED%/}/usr/bin/${PN}
make_wrapper ${PN} "solarus \"/usr/share/solarus/${PN}\"

make_desktop_entry "${PN}" "Zelda: Mystery of Solarus XD"
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}
5 changes: 2 additions & 3 deletions games-rpg/zsxd/zsxd-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -16,8 +16,7 @@ KEYWORDS="amd64 x86"
IUSE=""
RESTRICT="mirror bindist"

RDEPEND=">=games-engines/solarus-1.3.0
<games-engines/solarus-1.4.0"
RDEPEND="=games-engines/solarus-1.3.1"
DEPEND="app-arch/zip"

DOCS=( ChangeLog readme.txt )
Expand Down

0 comments on commit 60cc5cc

Please sign in to comment.