Skip to content

Commit

Permalink
games-emulation/mupen64plus-video-rice: Bump to 2.5.9
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 15, 2019
1 parent 6f2e8ff commit 611e4ca
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mupen64plus-video-rice/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mupen64plus-video-rice-src-2.5.9.tar.gz 300964 BLAKE2B 652d6642b743703488465883de2fe1e83e873316f133322fce343a6c8f3be37f351a1a91bad56ee1b4568afcafee55c1cb3cd6679159e24c552df63174751376 SHA512 98be11217024408e7c61120e7eb3cf83d6c9f666a029c7d0e85790c885c99e795336a8fa4f5029e546eba8cc139c6a5e84dd6c2ae5c60784a90c27ce58cd0603
DIST mupen64plus-video-rice-src-2.5.tar.gz 339012 BLAKE2B 861f350376e92c24a31955cc39ba33abef9930d4fd598619fd0a6b7ff746b1bb71e1644dfed3aebab902b09c4fcbd1a1755475b11676c6070fe92ea4f30b4802 SHA512 d3e9c3b3097ca9b9d896498bb34374a14ec1948fce8b795e755bb13a88f3066289fe2500666b4057e719bf3f1b38b840f8a60eaeccdcdddfab69b1986c953d61
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_P=${PN}-src-${PV}
inherit toolchain-funcs

DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gles2 cpu_flags_x86_sse"

RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
media-libs/libpng:0=
media-libs/libsdl2:0=[video]
virtual/opengl:0="
DEPEND="${RDEPEND}
virtual/pkgconfig"

S=${WORKDIR}/${MY_P}

src_prepare() {
default

# avoid implicitly appending CPU flags
sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
}

src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages

-C projects/unix

# this basically means: GNU userspace
UNAME=Linux

# verbose output
V=1

CROSS_COMPILE="${CHOST}-"
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"
PKG_CONFIG="$(tc-getPKG_CONFIG)"
# usual CFLAGS, CXXFLAGS and LDFLAGS are respected
# so we can leave OPTFLAGS empty
OPTFLAGS=

# paths, some of them are used at compile time
PREFIX=/usr
LIBDIR=/usr/$(get_libdir)

# disable unwanted magic
LDCONFIG=:
INSTALL_STRIP_FLAG=

# Package-specific stuff

# CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"

NO_ASM=$(usex cpu_flags_x86_sse 0 1)
USE_GLES=$(usex gles2 1 0)
)

use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
use x86 && MAKEARGS+=( HOST_CPU=i386 )

emake "${MAKEARGS[@]}" all
}

src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
dodoc README RELEASE
}

0 comments on commit 611e4ca

Please sign in to comment.