Skip to content

Commit

Permalink
dev-ada/libgpr: bump to 2021
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jun 2, 2021
1 parent b8221b2 commit 6140ecb
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/libgpr/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gprbuild-2020-20200429-19BD2-src.tar.gz 2489399 BLAKE2B 3a036cb40bbe5522af63c376a672384093901b44df6fd74013f1eff9d269c2f5056224ab5e7d59b6f3cf126cd14dd30420056b09e887851351462de59f700e3a SHA512 d2ff6a5d8281d332a31533c7a5744b6169fd250c9086373fd658486c1e529564d9830b9ef3b2dfcbec5f8c1ba50d244a9eb45bf8fdccd53f8b711dcf29258dfd
DIST gprbuild-2021-20210519-19A34-src.tar.gz 2572773 BLAKE2B 42244b96b48a10795812865a430a92a75f3e6a58f384a72e6941945707e712d239f2350e00bd94e6161fb19c6469197547f4ddb565e860ae1d08573b7c667997 SHA512 f2fd10cdf8bd2ae553184104a8d29ddf884329946c55e1a199d49358151e9f1ea25f6566d6e00d15e07d26ea4e84377f4ee137a9af4eecb862fc825dd987ada8
64 changes: 64 additions & 0 deletions dev-ada/libgpr/libgpr-2021.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ADA_COMPAT=( gnat_202{0..1} )
inherit ada toolchain-funcs multiprocessing

MYP=gprbuild-${PV}-${PV}0519-19A34-src
ID=23a77a37247ff811609e23a0a271f445c299fc8f
ADAMIRROR=https://community.download.adacore.com/v1

DESCRIPTION="Ada library to handle GPRbuild project files"
HOMEPAGE="http://libre.adacore.com/"
SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+shared static-libs static-pic"

RDEPEND="dev-ada/xmlada[shared?,static-libs?,static-pic?,${ADA_USEDEP}]
!net-libs/grpc"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"
REQUIRED_USE="${ADA_REQUIRED_USE}
|| ( shared static-libs static-pic )"

S="${WORKDIR}"/${MYP}

PATCHES=( "${FILESDIR}"/${PN}-2020-gentoo.patch )

src_configure() {
emake setup
}

src_compile() {
build () {
gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
-XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
}
if use shared; then
build relocatable
fi
if use static-libs; then
build static
fi
if use static-pic; then
build static-pic
fi
}

src_install() {
if use static-libs; then
emake prefix="${D}"/usr libgpr.install.static
fi
for kind in shared static-pic; do
if use ${kind}; then
emake prefix="${D}"/usr libgpr.install.${kind}
fi
done
rm -r "${D}"/usr/share/gpr/manifests || die
einstalldocs
}

0 comments on commit 6140ecb

Please sign in to comment.