forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/visp_camera_calibration: Bump to 0.10.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST vision_visp-0.10.0.tar.gz 1015180 SHA256 39097136f60f751b9365793442f2f8b7b0ed94f0383566dd0c31c83610ab2d22 SHA512 8e2652d6ca9c9535f1bebb628ec908f64c9fc89358bc92ed42ef12430b0b28c8ed3ed7935d2d3fe03c9761f9ac08e200eb59839ee2243df62d5934e8162cca9c WHIRLPOOL e542e26b6b4abad38c322c818a0ec14a9ce01c9c54bb04a2b920f001b2588eaa4da7f84b92c18cffabde894b8192afe4d4e7459d9977b0efe4d6556ca38580b8 | ||
DIST vision_visp-0.8.0.tar.gz 1010996 SHA256 5166e1f17601328d09716879ceb66135e07bdb71a375765a937e3b78a12b0e54 SHA512 2bf2d69b6e19de21b34869858672662162703ff8b2aea85fdb9a6dafa88d8fe1f97d18587e863f3f7c088697e931a1b6e4e2e37f31fc7caff0906e98debbad1a WHIRLPOOL 015778e4cff63a9dbb5bf5812e38f7564b68cb71886e472062be15ec31a87a7299bff7ef9df50124294e22906420f60075cf6cc69f77df1cd29267b401f655e5 | ||
DIST vision_visp-0.9.1.tar.gz 1014625 SHA256 918bf731a2fab8bd9fa082c0d0f86800710c79eeb9ec5e8b0c8d5baaffb7988d SHA512 f9ce23286fd9c7706364e9d63e6fb3881bad759aeea72313e5d2a24347f152ba90aab1c73d1b468ed3319e99f0a2bcb81208302825c83be686b9528f3b07469e WHIRLPOOL 8af772091c1c3fec475f32ff0d7232b728b3154491c4ed56300221c0ca96661c63c19baa50d6cdf010d1ffc304049f0ea1e7f5c403f15fb028b1417e41ed88b4 | ||
DIST vision_visp-0.9.3.tar.gz 1014883 SHA256 bf51470d167b1ee202dc55348ad54f6398f0f951b3af06fd32d0689b2fa98347 SHA512 e5775e410efefaaac00cdfaf07b65f9f77ade0e7d6f40b3d8345d7b594520f46741f56039c1eb0193c57287bafbddf8e755e10d6f85cc12ddefb2b997681f44a WHIRLPOOL 9163c1aa27f405213aa7290d9e7ecb4b4f6d0daf79879708bd9246fac9eeb3c6b816de3505729b17cb72357e684bb7af9db6688441c42b279089fbdd8116acc0 |
33 changes: 33 additions & 0 deletions
33
dev-ros/visp_camera_calibration/visp_camera_calibration-0.10.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
ROS_REPO_URI="https://github.com/lagadic/vision_visp" | ||
KEYWORDS="~amd64 ~arm" | ||
VER_PREFIX="kinetic-" | ||
ROS_SUBDIR=${PN} | ||
CATKIN_HAS_MESSAGES=yes | ||
PYTHON_COMPAT=( python{2_7,3_4} ) | ||
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs" | ||
|
||
inherit ros-catkin | ||
|
||
DESCRIPTION="Calibration of cameras using a customizable pattern and ViSP library" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-ros/camera_calibration_parsers | ||
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}] | ||
dev-ros/roscpp | ||
dev-ros/visp_bridge | ||
sci-libs/ViSP:= | ||
dev-libs/boost:= | ||
" | ||
DEPEND="${RDEPEND}" | ||
if [ "${PV#9999}" = "${PV}" ] ; then | ||
S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}" | ||
fi | ||
PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/boost.patch" ) |