Skip to content

Commit

Permalink
app-portage/iwdevtools: add 0.11.0
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jun 24, 2022
1 parent 765d034 commit 615ce19
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/iwdevtools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST iwdevtools-0.10.1.tar.gz 61117 BLAKE2B fd5508a40a854987db7f2ecc0e68e100cd6a8b6cc5b90a9901bbf6c16336ebc497861e05a6c1683ac9082aa9f12a03cb47f7116da793fbd8e105ed78aae2bbb3 SHA512 0f04850f15edc8af368a87bbc665c62d5588f4220c2d15ca5c0dd00d2c8135f7e1294217c8aec313650b7b7aae6433b87bdc32306c2c4c6e6747e55a13adbbe0
DIST iwdevtools-0.11.0.tar.gz 81975 BLAKE2B 241c04488cc3da265c1c5a0cbf90ddb938b4e0da10942094f25dcb1d32a0da314a80fba1fc99b1ec54a449905be8eddab896d67194d8e511c1a7378856fd7df2 SHA512 cccbe9461f27233e228529a5fe9c729620647b1e134c723f407bdd23b4fa85f04c6294fc6579a22667dec65b20ad1c26ac9d71b214407c49463aeed6fbaed7d1
64 changes: 64 additions & 0 deletions app-portage/iwdevtools/iwdevtools-0.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson optfeature

DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
app-misc/pax-utils
app-portage/portage-utils
>=app-shells/bash-5.1
dev-libs/libxml2:2
sys-apps/diffutils
sys-apps/file
sys-apps/portage
|| ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
|| ( sys-apps/util-linux app-misc/getopt )
test? ( ${RDEPEND} )"

src_configure() {
local emesonargs=(
-Ddocdir=${PF}
-Deprefix="${EPREFIX}"
-Dshellcheck=false
$(meson_use test)
)

has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )

meson_src_configure
}

pkg_postinst() {
optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail

if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Optional portage integration relies on using /etc/portage/bashrc."
elog "The example bashrc can be used as-is if not already using one:"
elog
elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "Otherwise, inspect the tools' --help output and the example to integrate"
elog "(if not defining the same phase functions, the example can be sourced)."
elog
elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
elog
elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
fi
}

0 comments on commit 615ce19

Please sign in to comment.