Skip to content

Commit

Permalink
dev-python/ansi2html: 1.5.1
Browse files Browse the repository at this point in the history
Re-enable test suite, add Python 3.7, EAPI 7, man page now shipped

Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
hartwork committed Oct 20, 2018
1 parent 8c80c15 commit 61638b0
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/ansi2html/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ansi2html-1.1.1.tar.gz 46591 BLAKE2B e2eb3d9b2665fd495ee8591a3cbfebcd1d565e
DIST ansi2html-1.2.0.tar.gz 46748 BLAKE2B c5ea7d35640f93562f6098a46dbeff9248e25b6210bfa5e71265d529599eea7713581ef986faa5afefb445492fe09d2170d164a63b2a602c57a79f2c72cbe118 SHA512 3106488da19cd093d7ae2a7499a66baf77877f47da0e497791cea2a63079c184f1d36743e78116b3faf08ab145ca97b5774151114b9ca193020578c8a3bdc860
DIST ansi2html-1.3.0.tar.gz 35989 BLAKE2B b2f949e2c559b2da91d3095b4d8ac2091bd15aad46b178a01aa59d4c900917e733f6ab3884d9c4c7c46bfa530936339d9b105a0471a09eb7a01693c43e8a87dd SHA512 73d1b3431e22146c4fe18fef4b05413231d79d627c396d67528d0aa1ab07a7ef4bcfeff56829b85d9fe9ad508599b782318911f7b10d6b9a1bc98780e31389d7
DIST ansi2html-1.4.2.tar.gz 25485 BLAKE2B 93f3bbd307b916c9ca60379235600606dbe16f1b6e423d0d2615f7825e92a6d7a8469ae7d60cf5131b4c3431897b3161bfcd2a0327525a332bcd6a6980dad5c9 SHA512 29c569839788968ba5a1fed8dddd4cc92f40ca88b4135b597815012ea44a44e8b7a3c2259d2d5d5f3cc690400be882236b88c0764a649da5679431501aab0b1c
DIST ansi2html-1.5.1.tar.gz 27133 BLAKE2B 8a8017b8f4edb878b105138ec0dfe3fbde8647315382d763eeae7f90f094b60f0cb7205718c75930ccb7ca1183e40e5205eca6f8362e20445d930d92db23bc22 SHA512 367fa9721de65a6e14118d65de9ea8ede1ecc9f0809115ecccf481947aa442409ca972442e51a75bc4f14913566255142da4e411fe060dfda5e55f84a7ac67af
45 changes: 45 additions & 0 deletions dev-python/ansi2html/ansi2html-1.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )

inherit distutils-r1

DESCRIPTION="Convert text with ANSI color codes to HTML"
HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
DEPEND="
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
)
dev-python/setuptools[${PYTHON_USEDEP}]
"

src_compile() {
distutils-r1_src_compile
}

python_test() {
chmod -x "${S}"/tests/* || die
esetup.py check
esetup.py test
}

python_install_all() {
doman man/${PN}.1
DOCS=( README.rst man/${PN}.1.txt )
distutils-r1_python_install_all
}

0 comments on commit 61638b0

Please sign in to comment.