Skip to content

Commit

Permalink
media-libs/libwebp: bump to 0.5.1
Browse files Browse the repository at this point in the history
  • Loading branch information
floppym committed Aug 16, 2016
1 parent e1259af commit 6182a16
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libwebp/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST libwebp-0.3.0.tar.gz 800793 SHA256 8903fca40ece603b9cb20d32105168da7e2a33be
DIST libwebp-0.3.1.tar.gz 844799 SHA256 b37932c625322a69fe4e9b88884b5c7aed2b3eaf9fd5e5b480aee339a92e6ee7 SHA512 9b962ce8ce696eb1cc78de624abe0371f9143449cbc8978eb6327e40afe95b31c1b4c9aa97e9c3f4ada46c2f2b70d7b1ca59e46046ddbb3546ecb8e3e766922f WHIRLPOOL ce1fc294b951f75b5a9ca3048f73a9eff8f9e7f413370b36f9c6ceda8d11fad8bb4ff621d55ad4e3c8b6c829eceecf79f3892d464971e76aa2c0edc8fa32f2f6
DIST libwebp-0.4.0.tar.gz 887880 SHA256 31913577e96386556855b41d210736449445fe96cfbe9289014e9b8afa944d69 SHA512 b0229bcbdf04f667cb0957738a199e08a1340d936c88ef69ad6436da7280a337a94579f4f315b478b74a72a49c126be4222c36c5e2184d429750b9ddc76ff2d6 WHIRLPOOL 8e9edfc589b41d8c076b56cf81d5a21976ad4d1b5aad9b39ed8cadd5fd520bab5fc7b6b3d036c7d7e265218b3eb3adcd1fac4bef180e2c096bac663e55489808
DIST libwebp-0.4.2.tar.gz 977801 SHA256 14d825d7c2ef7d49621bcb6b83466be455585e671ae0a2ebc1f2e07775a1722d SHA512 0213f92cc9a4303b9ae51ffbc72c083880bcd5c1d8b2f92fe514e0a11167925934d01155f89dc9e571dee51293ea26f8b8b486c5b980db20e921d653320a4d13 WHIRLPOOL be219a80a6a427f19c2ad2943a37e51b7e9c6b5509ad910bfe58ced386cb1d12e78e059ac7028987ee2942d5bdfc9d52e0051e13f14de2aea0088f6abb92a6ef
DIST libwebp-0.5.1.tar.gz 1212254 SHA256 6ad66c6fcd60a023de20b6856b03da8c7d347269d76b1fd9c3287e8b5e8813df SHA512 931b2dce29ee664d9a0bbc614ed19992c3ca52dd886d504dcca2df82c8f815e723bd03be7ae35a186ae555b09b0e31a17eb834871ff0728ab15ab24548b630ee WHIRLPOOL 4026ba52ba05fe48f135f566ba2b5566e32ff10bedc3cef6641ad9e6dd13fb72b117e55e8f5e6aab0549d9b2348cd3bcf40a740f86086963590aa080c06bbaa7
65 changes: 65 additions & 0 deletions media-libs/libwebp/libwebp-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils libtool multilib-minimal

DESCRIPTION="A lossy image compression format"
HOMEPAGE="https://developers.google.com/speed/webp/download"
SRC_URI="http://downloads.webmproject.org/releases/webp/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/6" # subslot = libwebp soname version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~m68k-mint"
IUSE="experimental gif +jpeg opengl +png static-libs swap-16bit-csp tiff"

# TODO: dev-lang/swig bindings in swig/ subdirectory
RDEPEND="gif? ( media-libs/giflib:= )
jpeg? ( virtual/jpeg:0= )
opengl? (
media-libs/freeglut
virtual/opengl
)
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0= )"
DEPEND="${RDEPEND}"

ECONF_SOURCE=${S}

src_prepare() {
default

# Fix libtool relinking, bug 499270.
#elibtoolize
eautoreconf
}

multilib_src_configure() {
local args=(
--enable-libwebpmux
--enable-libwebpdemux
--enable-libwebpdecoder
$(use_enable static-libs static)
$(use_enable swap-16bit-csp)
$(use_enable experimental)
$(use_enable jpeg)
$(use_enable png)
$(use_enable opengl gl)
$(use_enable tiff)

# Only used for gif2webp binary wrt #486646
$(multilib_native_use_enable gif)
)

econf "${args[@]}"
}

multilib_src_install() {
emake DESTDIR="${D}" install
}

multilib_src_install_all() {
prune_libtool_files
dodoc AUTHORS ChangeLog doc/*.txt NEWS README{,.mux}
}

0 comments on commit 6182a16

Please sign in to comment.