Skip to content

Commit

Permalink
dev-libs/ell: bump to 0.28
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Feb 9, 2020
1 parent fec7aad commit 618ee7d
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/ell/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,4 +6,5 @@ DIST ell-0.24.tar.xz 473332 BLAKE2B 97b5f5de1a4680f5b8da5db8d151df56d2eadb511c54
DIST ell-0.25.tar.xz 473392 BLAKE2B cefb71c0bd1c30a1c2e85baf19097f9028b3d2d1e8df14beb231f3c52f39e2ec98fbafdfbba4c05e94328c0c5747eb49111e1c76b3cb02fe22c09b51a5016f17 SHA512 7f12e2dfae16a38750166787ede7e3bf6def1e15a8bcb33bdba80ff84c2930d1857437f4ab871c408a52b18fec2212856ae9190ddf5eb542e90ebc76edd1f693
DIST ell-0.26.tar.xz 473512 BLAKE2B bad1545b65caad7263e03156740ef5dfc401536fc063f34bdac5346a9edca8b7b16fd175abb264a6163e9dca87d1469f388984a95962dcc695e3e98549ff2a0a SHA512 b7a841f6e3c50077b60c210549744344ee70b5116bc9ee0f44dfea896f68fe6ab89a6fa38fcfe04e259648de978162aa5592f2e07accf13825584b40d57ef6cb
DIST ell-0.27.tar.xz 474412 BLAKE2B 3b7d7ccfff8a92bbe930032b6a54bdc91b6541d1e6d8e514f1e49fcd08f3f5bc47beb3722dc864a63dcbbd72f793fbc2bc590b168f1623ff6e7088fbc960acb1 SHA512 ecda285155ef5ac1b8bdeabfba2e972149a5027c85236af74366c735aec7304b2dee8ff6aa931000b4299e8bb7654e7d4a63c1738de6e6e740f5ba16467f2823
DIST ell-0.28.tar.xz 474880 BLAKE2B 2c571f952056c9f4e3e8c245b2b57645c4baa2935fdbe758170dcfe689f4db2162322f25a80cc5a7d4d5bded6159d1fa0d583be979a2708d32e61e91d1ced585 SHA512 6c3aef4d403878c0c9b8a1e5e8861656f2abbab19dd275b1aecca899ca615c00aee30e18f194435ec6be859adcffbe3703a79b13508e1e76c2192ec51f7c0cd7
DIST ell-0.9.tar.xz 396968 BLAKE2B 566735cedd3525c4fd3fec9cec0e9b089dd60c6b79416a9c254c771729b6db9137af050f4c7f9c4c6dfa1ce33b8c7d41b877c9e3caa582c6ab9be716bd986a8b SHA512 e1208066012b9ff927baae271f94116376ccd2577d7f6510cc1444eee912988aa1c25e8e8c9195cccfa39ed48fc8c2f07bd7a414719e6ce76ee1e5bd2a64b8c3
46 changes: 46 additions & 0 deletions dev-libs/ell/ell-0.28.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic multilib-minimal

DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
HOMEPAGE="https://01.org/ell"
if [[ "${PV}" == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
else
SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi
LICENSE="LGPL-2.1"
SLOT="0"

IUSE="glib pie"

RDEPEND="
glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"

src_prepare() {
default
[[ "${PV}" == *9999 ]] && eautoreconf
}

multilib_src_configure() {
append-cflags "-fsigned-char" #662694
local myeconfargs=(
$(use_enable glib)
$(use_enable pie)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
local DOCS=( ChangeLog README )
einstalldocs

find "${ED}" -name "*.la" -delete || die
}

0 comments on commit 618ee7d

Please sign in to comment.