Skip to content

Commit

Permalink
net-wireless/unifi: bump to 5.12.37
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Nov 20, 2019
1 parent 8399882 commit 619c43b
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-wireless/unifi/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST unifi-5.12.22.zip 114666138 BLAKE2B 836de0621a0241cfedf25d48bbd28651968ff57218cbe32f192bbac996756f4d99cbe0454e41fb4b8354d8731a7546a78c5698b1b880ccdda251c6d4dc495ada SHA512 c86b586408cc3117263d62e218d5e5ba989d120b38da42acfa8f14461b65d3e739ac8111fa3b13f2c93c0026b3b049af1e29cb7d381085ff54e596c0efe0c60e
DIST unifi-5.12.31.zip 114683904 BLAKE2B e6de4193b7562665c43f7d28ad75dc0674bb37d65fce6f7fd2b868dbcec26a9f36b1e96fbbfbdbe0368960d0c696d58389453051c0faa95fe5839afd257ae9e1 SHA512 8bb31c5b83cf9f60f07923e649aead7120eebb45d9562a92a3697c7e1e3e5476cefb5f6a0da85c3922797ddfef9d12e704d47bfb1bf5c6431ead4598cb86bf75
DIST unifi-5.12.35.zip 114691419 BLAKE2B 0400f78cbc880f52e8e352a1b8ef925c293b5a51137aaba89c4e26f7b213661e2b9e5caf09cfc6af0f74456e1217f4e2b8f398c11ebe32b1b6a17153cef9e920 SHA512 4e6b3726e5b6e43c1688fbdefe816eedb1cefc671bc9f861cc06f1c4f52a903670e033c2c5b2c66c5ed2c3f42e8f573e6245fe483a32a0df33283d46ccb5d96a
DIST unifi-5.12.37.zip 115477591 BLAKE2B 7e50d7e89953e9b4d829eddad89880db06a981ec8182d9ab412d988d80e7df51ad501b0ceb14314d76103060cd438c35509893ac9ce7bd44af9162d93c40d5c0 SHA512 74256a26b68b354951729e69de7521479340a8522965ee7bff4d622d4ae8782a66ddc5ec4852600bc333383e732b15ddc41ad8adb133e820f61456710508a354
DIST unifi-5.6.42.zip 63581448 BLAKE2B dc12149acc56587043b9f6c45a43327a9a067dda86127c60ad62a4681a0c8ba873435b60183989332f561fb52f71c7207480766ec23d9c0e892cc20c521a9819 SHA512 467c0ad284a84795537484f371867d851e67c7e396215d539a9705f17f374b50db4051121a6634d1944474a2474bdd75fca860ab00b48634a5d3e8749a122989
73 changes: 73 additions & 0 deletions net-wireless/unifi/unifi-5.12.37.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# Set this var for any releases except stable
RC_SUFFIX="-84910278c6"

inherit systemd

DESCRIPTION="A Management Controller for Ubiquiti Networks UniFi APs"
HOMEPAGE="https://www.ubnt.com"
SRC_URI="https://dl.ui.com/unifi/${PV}${RC_SUFFIX}/UniFi.unix.zip -> ${P}.zip"

KEYWORDS="~amd64"
LICENSE="Apache-1.0 Apache-2.0 BSD-1 BSD-2 BSD CDDL EPL-1.0 GPL-2 LGPL-2.1 LGPL-3 MIT ubiquiti"
SLOT="0/5.12"
IUSE="systemd"

RDEPEND="
acct-group/unifi
acct-user/unifi
dev-db/mongodb
virtual/jre:1.8
"

DEPEND="app-arch/unzip"

RESTRICT="bindist mirror"

S="${WORKDIR}/UniFi"

DOCS=( "readme.txt" )

QA_PREBUILT="usr/lib/unifi/lib/native/Linux/x86_64/*.so"

src_prepare() {
# Remove unneeded files Linux, Mac and Windows
rm -r lib/native/Linux/{aarch64,armv7} lib/native/{Mac,Windows} || die
if ! use systemd; then
rm lib/native/Linux/x86_64/libubnt_sdnotify_jni.so || die
fi

default
}

src_install() {
# Install MongoDB wrapper script, to avoid problems with >= 3.6.0
# See https://community.ubnt.com/t5/UniFi-Routing-Switching/MongoDB-3-6/td-p/2195435
exeinto /usr/lib/unifi/bin
newexe "${FILESDIR}"/mongod-wrapper mongod

insinto /usr/lib/unifi
doins -r dl lib webapps

diropts -o unifi -g unifi
keepdir /var/lib/unifi/{conf,data,run,tmp,work} /var/log/unifi

for symlink in conf data run tmp work; do
dosym ../../../var/lib/unifi/${symlink} /usr/lib/unifi/${symlink}
done
dosym ../../../var/log/unifi /usr/lib/unifi/logs

newinitd "${FILESDIR}"/unifi.initd-r1 unifi
systemd_dounit "${FILESDIR}"/unifi.service

newconfd "${FILESDIR}"/unifi.confd unifi

echo 'CONFIG_PROTECT="/var/lib/unifi"' > "${T}"/99unifi || die
doenvd "${T}"/99unifi

einstalldocs
}

0 comments on commit 619c43b

Please sign in to comment.