Skip to content

Commit

Permalink
dev-perl/Net-SSLeay: Bump to version 1.820.0 re bug #614462
Browse files Browse the repository at this point in the history
- Replace sed hacks with real patches ( metadata retroactively pulled
  from git history and reconstructed to retain intent, as the existing
  sed commands had entirely ceased working, silently )

Upstream:
- Implement SSL_{CTX_,}set_psk_client_callback()
- Support NPN-less libressl
- Skip NPN-test with libressl
- Free ocsp_response only when allocated
- Lots of new bindings
- Fix key block size calculation with AEAD ciphers
- Fix test failures without '.' in @inc

Bug: https://bugs.gentoo.org/614462
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
kentfredric committed Nov 26, 2017
1 parent 20bb1e8 commit 619e624
Show file tree
Hide file tree
Showing 5 changed files with 140 additions and 1 deletion.
3 changes: 2 additions & 1 deletion dev-perl/Net-SSLeay/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Net-SSLeay-1.81.tar.gz 396631 SHA256 00cbb6174e628b42178e1445c9fd5a3c5ae2cfd6a5a43e03610ba14786f21b7d SHA512 8d4b72ede74ea22cf2ed681a8441f40965331cd5d4442c19677cf5bc7c1e61ed1e50d0f3a4f1b272428485bcc132ec99b0c75344ca43e8a34a9dd15539719f55 WHIRLPOOL 125710fcabce6f9ba2515bb04a90513d0f2ab2f57546187044bc7f4f45b0ba354f747674fcebfad41dced608603e8c811bce58a66e104efd90205a4b2102d417
DIST Net-SSLeay-1.81.tar.gz 396631 BLAKE2B dfd0f14bbeb3196009d7e597c0c933dbe9cb7f9d4591ae62adc94a94d1b67d6e108992c7053defcea9b0c6dad90be3b26c1d53cea9e87a09016964d09fe2c5bd SHA512 8d4b72ede74ea22cf2ed681a8441f40965331cd5d4442c19677cf5bc7c1e61ed1e50d0f3a4f1b272428485bcc132ec99b0c75344ca43e8a34a9dd15539719f55
DIST Net-SSLeay-1.82.tar.gz 399194 BLAKE2B 0c8aeb3085b102b71284266904ee88a8558070644aaa6dd0c5f78db0bfccb0e7456c8ba62a549d7ab245a02ddc7e856bc326d503f63268ee0761290e41b97e4d SHA512 758c41f4916a55b5085167e5c6a2732a5ee70dbeb8f42e791cd957957ba4a59f724c072d3fa50a6b42ae3b22cf3ecb8738c3f8963990a7030117b73c2dcc0716
57 changes: 57 additions & 0 deletions dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=MIKEM
DIST_VERSION=1.82
DIST_EXAMPLES=("examples/*")
inherit multilib perl-module

DESCRIPTION="Perl extension for using OpenSSL"

LICENSE="openssl"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="libressl test minimal examples"

RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
virtual/perl-MIME-Base64
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
!minimal? (
dev-perl/Test-Exception
dev-perl/Test-Warn
dev-perl/Test-NoWarnings
)
virtual/perl-Test-Simple
)
"
export OPTIMIZE="$CFLAGS"
export OPENSSL_PREFIX=${EPREFIX}/usr

PATCHES=(
"${FILESDIR}/${PN}-1.82-respect-cflags.patch"
"${FILESDIR}/${PN}-1.82-fix-libdir.patch"
"${FILESDIR}/${PN}-1.82-fix-network-tests.patch"
)

src_prepare() {
use test && perl_rm_files 't/local/01_pod.t' 't/local/02_pod_coverage.t' 't/local/kwalitee.t'
perl-module_src_prepare
}

src_configure() {
if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
export NETWORK_TESTS=yes
else
use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
export NETWORK_TESTS=no
fi
export LIBDIR=$(get_libdir)
perl-module_src_configure
}
26 changes: 26 additions & 0 deletions dev-perl/Net-SSLeay/files/Net-SSLeay-1.82-fix-libdir.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 7beee46a64a9af1a7edf6bb9011327b4a08e353a Mon Sep 17 00:00:00 2001
From: Torsten Veller <[email protected]>
Date: Mon, 16 Jul 2012 05:31:43 +1200
Subject: Fix libdir

Bug: https://bugs.gentoo.org/416339
---
inc/Module/Install/PRIVATE/Net/SSLeay.pm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/inc/Module/Install/PRIVATE/Net/SSLeay.pm b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
index 49913e6..0a3aa24 100644
--- a/inc/Module/Install/PRIVATE/Net/SSLeay.pm
+++ b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
@@ -67,7 +67,7 @@ sub ssleay_get_build_opts {
for ("$prefix/include", "$prefix/inc32", '/usr/kerberos/include') {
push @{$opts->{inc_paths}}, $_ if -f "$_/openssl/ssl.h";
}
- for ($prefix, "$prefix/lib64", "$prefix/lib", "$prefix/out32dll") {
+ for ($prefix, "$prefix/$ENV{LIBDIR}", "$prefix/out32dll") {
push @{$opts->{lib_paths}}, $_ if -d $_;
}

--
2.14.3

29 changes: 29 additions & 0 deletions dev-perl/Net-SSLeay/files/Net-SSLeay-1.82-fix-network-tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
From 36c14369372f0371e033019c9cea197b31a93bde Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Sat, 5 Mar 2016 12:41:11 +1300
Subject: Fix network tests re: Networking

---
inc/Module/Install/PRIVATE/Net/SSLeay.pm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/inc/Module/Install/PRIVATE/Net/SSLeay.pm b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
index 0a3aa24..f27b43f 100644
--- a/inc/Module/Install/PRIVATE/Net/SSLeay.pm
+++ b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
@@ -46,11 +46,7 @@ EOM
LIBS => join(' ', (map {"-L$_"} @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
);

- if ( $self->prompt(
- "Do you want to run external tests?\n".
- "These tests *will* *fail* if you do not have network connectivity.",
- 'n',
- ) =~ /^y/i ) {
+ if ( 'yes' eq ( $ENV{NETWORK_TESTS} || '' ) ) {
$self->tests('t/*/*.t t/*/*/*.t');
} else {
$self->tests('t/local/*.t t/handle/local/*.t');
--
2.14.3

26 changes: 26 additions & 0 deletions dev-perl/Net-SSLeay/files/Net-SSLeay-1.82-respect-cflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 8472348e588c16ad5332fe0b1f1dc9cc8eb4ab7d Mon Sep 17 00:00:00 2001
From: Torsten Veller <[email protected]>
Date: Mon, 16 Jul 2012 05:31:43 +1200
Subject: Respect CFLAGS

Bug: https://bugs.gentoo.org/378657
---
inc/Module/Install/PRIVATE/Net/SSLeay.pm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/inc/Module/Install/PRIVATE/Net/SSLeay.pm b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
index 5abcf70..49913e6 100644
--- a/inc/Module/Install/PRIVATE/Net/SSLeay.pm
+++ b/inc/Module/Install/PRIVATE/Net/SSLeay.pm
@@ -129,7 +129,7 @@ EOM

if (($Config{cc} =~ /aCC/i) && $^O eq 'hpux') {
print "*** Enabling HPUX aCC options (+e)\n";
- $opts->{optimize} = '+e -O2 -g';
+ $opts->{optimize} = '+e ' . $opts->{optimize};
}

if ( (($Config{ccname} || $Config{cc}) eq 'gcc') && ($Config{cccdlflags} =~ /-fpic/) ) {
--
2.14.3

0 comments on commit 619e624

Please sign in to comment.