Skip to content

Commit

Permalink
dev-ml/eliom: bump to 5.0.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jan 30, 2016
1 parent f7786b7 commit 61a1c03
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/eliom/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eliom-4.2.tar.gz 699337 SHA256 30d180b72d21177d09b311785e08e54cc221b148d969f17334f8be6eecfb783d SHA512 c7c75dc00defe0c269aba4e4fbdc00a824b781b124e3f51747e29533c4aeedaecb68c7ebcb38b4cc9a51c3796abdfa680ba0702a83415911406b25cd07ad66c7 WHIRLPOOL 2a36deeb10cbf3b29c76b33185de1c848615293830f7a3701c2d87025be0ed575cdadf238c696ad4716e50f2b0258febef7b7039a1980aafeaf6e1c483ec46ca
DIST eliom-5.0.0.tar.gz 728278 SHA256 6726500f9a54478def95875d04098dc8dc829d4a10e06896ff4f037bb1c03cbd SHA512 1c5297e376c3a46935de369b418638a772304246b73756f8bc052301b48d62a37af527274bf1a05064f33b60ff9dcde057a0030f083136fa4e1c0cfa07f01887 WHIRLPOOL ca1186787a8f938cf029f9a5c9904ed0324a3d24d2f0d0834dd1e2b2f995de6d57d1040b4d128de8233255ca385478f0ba3bf597c2f0315ab2f1894118755dca
57 changes: 57 additions & 0 deletions dev-ml/eliom/eliom-5.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib findlib

DESCRIPTION="A web framework to program client/server applications"
HOMEPAGE="http://ocsigen.org/eliom/"
SRC_URI="https://github.com/ocsigen/eliom/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="doc +ocamlopt ppx"

RDEPEND=">=dev-lang/ocaml-4.00:=[ocamlopt?]
>=dev-ml/js_of_ocaml-2.5-r1:=
>=www-servers/ocsigenserver-2.5:=
>=dev-ml/tyxml-3.6:=
>=dev-ml/deriving-0.6:=
>=dev-ml/reactiveData-0.2:=
dev-ml/ocaml-ipaddr:=
dev-ml/react:=
dev-ml/ocaml-ssl:=
>=dev-ml/lwt-2.5.0:=
dev-ml/calendar:=
ppx? ( dev-ml/ppx_tools:= )"
DEPEND="${RDEPEND}
dev-ml/opam"

src_compile() {
if use ocamlopt ; then
emake PPX=$(usex ppx true false) all
else
emake PPX=$(usex ppx true false) byte
fi
use doc && emake doc
emake man
}

src_install() {
opam-installer \
--prefix="${ED}/usr" \
--libdir="${D}/$(ocamlc -where)" \
--docdir="${ED}/usr/share/doc/${PF}" \
--mandir="${ED}/usr/share/man" \
|| die
dodoc CHANGES README.md
if use doc ; then
docinto client/html
dodoc -r _build/src/lib/client/api.docdir/*
docinto server/html
dodoc -r _build/src/lib/server/api.docdir/*
fi
}
3 changes: 3 additions & 0 deletions dev-ml/eliom/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">ocsigen/eliom</remote-id>
</upstream>
<use>
<flag name="ppx">Enable PPX syntax extension support.</flag>
</use>
</pkgmetadata>

0 comments on commit 61a1c03

Please sign in to comment.