Skip to content

Commit

Permalink
dev-python/elasticsearch-curator: bump to 4.2.4
Browse files Browse the repository at this point in the history
  • Loading branch information
hydrapolic authored and gktrk committed Dec 27, 2016
1 parent b0c2970 commit 61aee0d
Show file tree
Hide file tree
Showing 2 changed files with 122 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/elasticsearch-curator/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST elasticsearch-2.4.0.tar.gz 27364449 SHA256 3ae01140ae7bcbb91436feef381fbed774e36ef6d1e8e6a3153640db82acf4c9 SHA512 931f4d42cba43131718ec7480439b5fda0b9222a51cf9639d99ab4c00bdbedbe7e8da7a6016d88b848772cd416bc49fe7af09202160cecf839e39d803b45e869 WHIRLPOOL e03a2f7a6ea5913ce112b82e8578183c401f2d5901070a77c509ddbe7333fe62622fb2bb3e0f786a914bb15c56793e8b13220ae4588271baa3bbbcdf86223f47
DIST elasticsearch-5.1.1.tar.gz 33291322 SHA256 cd45bafb1f74a7df9bad12c77b7bf3080069266bcbe0b256b0959ef2536e31e8 SHA512 2b5faf97c5ff41a9f12e21749d60f3632b39987d4886713ee9646110acdd17323d263168980d7dd4035732556b604acd68dc37ae7b805d84493075776b9d7bcd WHIRLPOOL ebb46d4a5643f09c0c903055c407a54d46264347924ca37cc73adfee3dd8a9bf2157b1be92b9b1d85636ea92b2d1f89d558c5413c804412996ea9bce42f1c3c6
DIST elasticsearch-curator-4.0.6.tar.gz 110804 SHA256 e60f671dfa003f45f68320599cb15cee38cc61cb25899d903c2b29f2e3892e09 SHA512 b52af17d7d58bb9599095a00d03e5fda6bc7d9b401d100379f2a6969e5f995367192f33c045251518345abd86f2b143b1b086aab2c165d7e66efccb02dab8698 WHIRLPOOL 7621d883d59202882f455393ca7a87b39292667890dd2c5e3841ffb8a62e823d775794173a0205b02da24b7016509759c302bfabee5fc77a8000c961f853466f
DIST elasticsearch-curator-4.1.2.tar.gz 130194 SHA256 f4ccc0d49790e0f9390982cc2f0c69ad385361e7840050b6ecba4ef70fa64a0d SHA512 4a465c03baea6b708ce38bbaea8c94a288f91db39fba253a3123af68bce94b1253d22f0d9214fc449a97d55ad468f7f78bf14993c0f5cf18fcf91ebbe1ec57cb WHIRLPOOL 73f8b59f08a6746468336aaac9217a4e37ee15e0deeaf9711d7af79585dfe4e18402d6dceb3feafbafec3e2609dbcc7df983555529640e046336e0bb7421f0d3
DIST elasticsearch-curator-4.2.4.tar.gz 225965 SHA256 620667cb62e7fc04f8c41e3b11a0a66ccdae0ba6de1a65a6fa3fd748e6b29560 SHA512 dd85dd9a19c2371b3f731ef78259adaaedd39b944980ed11b89a076b53bbc74d44751acb050aeda7fbe47207ff457c7ba4cb7eba88967092e9c9a525d0a1380c WHIRLPOOL 034a17e72289a3b555d07be39ce1522819ef1d9ead0c20bfd88e6e2b44ac029bd9266215dcb0f55b7d5db4914d31d31240a9e94218aa8ef1cc36aea016f767fc
120 changes: 120 additions & 0 deletions dev-python/elasticsearch-curator/elasticsearch-curator-4.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,120 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

MY_PN="curator"
ES_VERSION="5.1.1"

inherit distutils-r1

DESCRIPTION="Tending time-series indices in Elasticsearch"
HOMEPAGE="https://github.com/elasticsearch/curator"
SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND="
>=dev-python/elasticsearch-py-2.4.0[${PYTHON_USEDEP}]
<dev-python/elasticsearch-py-3.0.0[${PYTHON_USEDEP}]
>=dev-python/click-6.0[${PYTHON_USEDEP}]
>=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.8.3[${PYTHON_USEDEP}]
>=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
|| ( virtual/jre:1.8 virtual/jre:1.7 )
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/nosexcover[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}] )"

S="${WORKDIR}/${MY_PN}-${PV}"

python_test() {
ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
ES_PORT="25123"
ES_LOG="${ES}/logs/elasticsearch.log"
PID="${ES}/elasticsearch.pid"

# run Elasticsearch instance on custom port
sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
s/#cluster.name: my-application/cluster.name: gentoo-es-curator-test/g" \
"${ES}/config/elasticsearch.yml" || die

# Elasticsearch 1.6+ needs to set path.repo
grep -q "^path.repo" "${ES}/config/elasticsearch.yml"
if [[ $? -ne 0 ]]; then
echo "path.repo: /" >> "${ES}/config/elasticsearch.yml" || die
fi

# start local instance of elasticsearch
"${ES}/bin/elasticsearch" -d -p "${PID}" || die

local i
for i in {1..10}; do
grep -q "started" ${ES_LOG} 2> /dev/null
if [[ $? -eq 0 ]]; then
einfo "Elasticsearch started"
eend 0
break
elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
eend 1
eerror "Elasticsearch already running"
die "Cannot start Elasticsearch for tests"
else
einfo "Waiting for Elasticsearch"
eend 1
sleep 2
continue
fi
done

export TEST_ES_SERVER="localhost:${ES_PORT}"
esetup.py test || die

pkill -F ${PID}
}

python_prepare_all() {
# avoid downloading from net
sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die

# test test_no_config fails because by default it connects
# to port 9200 and we run es on custom port
# https://github.com/elastic/curator/issues/843
sed -e '39,57d' -i test/integration/test_cli.py || die

distutils-r1_python_prepare_all
}

python_compile_all() {
cd docs || die
emake man $(usex doc html "")
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
doman docs/_build/man/*
distutils-r1_python_install_all
}

pkg_postinst() {
ewarn ""
ewarn "For Python 3 support information please read: http://click.pocoo.org/3/python3/"
ewarn ""
ewarn "Example usage on Python 3:"
ewarn "export LC_ALL=en_US.UTF-8"
ewarn "export LANG=en_US.UTF-8"
ewarn "curator ..."
}

0 comments on commit 61aee0d

Please sign in to comment.