Skip to content

Commit

Permalink
dev-ruby/shoulda-context: add 1.2.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
graaff committed Nov 7, 2016
1 parent 6aafb7f commit 61c943b
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/shoulda-context/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST shoulda-context-1.2.1.gem 24064 SHA256 a52c1ce8aeb868af7a1f98d63f748bfdea353f98bce35181ed2bffa266149b1b SHA512 eda6f82c101d0abdf517cabd9663a6a45d9e3d1ef19bdc51d4de35a45e18de15b1aee02a7a557460a3a9b1eafa61cd892240563b6f239b94339e9869c6e63ef3 WHIRLPOOL 9a5fa8ab2e8f1511512ea82ca7d4883157174f10c2b40a76f8020839cfa946964249acd5540b8582f269952574a32866d03a463520176ddf9e1671668b1999af
DIST shoulda-context-1.2.2.gem 24064 SHA256 6c25ac1938b9009807c37c2e497fac84f768db3c89d67688459a2ce6bb6616d0 SHA512 b09f5ce2db59bbb26d5678b17b6641b79df7983d25e81a31bc10c42b702bdba09795b692d711d59c103beb2f691b503567e37c46668f77e600416551ef2c5e05 WHIRLPOOL 0fa227622d36d504ad62e347d735239974706644135e97a662476961d3f1420248d6a78207a125b1623be6cbee3396b2507682f0dc8b099ace919bacb9d3df7f
37 changes: 37 additions & 0 deletions dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"

RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"

# Don't install the conversion script to avoid collisions with older
# shoulda.
RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Context framework extracted from Shoulda"
HOMEPAGE="http://thoughtbot.com/projects/shoulda"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
IUSE="doc test"

ruby_add_bdepend "test? ( dev-ruby/test-unit:2
<dev-ruby/mocha-1 )"

all_ruby_prepare() {
sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
}

each_ruby_test() {
BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
}

0 comments on commit 61c943b

Please sign in to comment.