Skip to content

Commit

Permalink
games-arcade/insaneodyssey: Re-bootstrap autotools
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/724418
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jul 5, 2020
1 parent efd1894 commit 61e5647
Show file tree
Hide file tree
Showing 3 changed files with 31 additions and 26 deletions.
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- a/io.cpp.orig 2004-06-01 19:11:16.000000000 +0300
+++ b/io.cpp 2004-06-01 19:21:14.000000000 +0300
--- a/insaneodyssey/io.cpp
+++ b/insaneodyssey/io.cpp
@@ -42,7 +42,11 @@
{
SDL_Surface *image, *surface;
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Bug: https://bugs.gentoo.org/600894

--- a/io.cpp
+++ b/io.cpp
--- a/insaneodyssey/io.cpp
+++ b/insaneodyssey/io.cpp
@@ -22,6 +22,7 @@
#include <stdlib.h>
#include <stdio.h>
Expand Down
49 changes: 27 additions & 22 deletions games-arcade/insaneodyssey/insaneodyssey-000311-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop
EAPI=7

inherit autotools desktop

DESCRIPTION="Help West Muldune escape from a futuristic mental hospital"
HOMEPAGE="http://members.fortunecity.com/rivalentertainment/iox.html"
Expand All @@ -13,48 +14,52 @@ SRC_URI="mirror://gentoo/io${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="media-libs/libsdl[sound,video]
DEPEND="
media-libs/libsdl[sound,video]
media-libs/sdl-mixer
media-libs/sdl-image
"
media-libs/sdl-image"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}"

src_prepare() {
default

cd ${PN}

PATCHES=(
# Modify data load code and paths to game data
eapply "${FILESDIR}"/${P}-datafiles.patch
"${FILESDIR}"/${P}-datafiles.patch
"${FILESDIR}"/${P}-gcc6.patch
)

eapply "${FILESDIR}"/${P}-gcc6.patch
src_prepare() {
default

sed -i \
-e "/lvl/s:^:/usr/share/${PN}/:" \
-e "s:night:/usr/share/${PN}/night:" \
levels.dat || die
insaneodyssey/levels.dat || die
sed -i \
-e "s:tiles.dat:/usr/share/${PN}/tiles.dat:" \
-e "s:sprites.dat:/usr/share/${PN}/sprites.dat:" \
-e "s:levels.dat:/usr/share/${PN}/levels.dat:" \
-e "s:IO_T:/usr/share/${PN}/IO_T:" \
-e "s:tiles.att:/usr/share/${PN}/tiles.att:" \
-e "s:shot:/usr/share/${PN}/shot:" \
io.cpp || die
insaneodyssey/io.cpp || die
sed -i \
-e 's:\[32:[100:' \
io.h || die
insaneodyssey/io.h || die

mv configure.{in,ac} || die
eautoreconf
}

src_install() {
cd ${PN}
dobin ${PN}
insinto /usr/share/${PN}
cd insaneodyssey || die

dobin insaneodyssey

insinto /usr/share/insaneodyssey
doins *bmp *png *dat *att *lvl *wav *mod *IT
newicon west00r.png ${PN}.png
make_desktop_entry ${PN} "Insane Odyssey"

newicon west00r.png insaneodyssey.png
make_desktop_entry insaneodyssey "Insane Odyssey"
}

0 comments on commit 61e5647

Please sign in to comment.