Skip to content

Commit

Permalink
dev-haskell/semigroups: fix build failure with USE=-*, bug #582744
Browse files Browse the repository at this point in the history
Reported-by: Thomas Beutin
Bug: https://bugs.gentoo.org/582744

Package-Manager: portage-2.2.28
  • Loading branch information
Sergei Trofimovich committed May 12, 2016
1 parent 8dc13f6 commit 61e7ac4
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-haskell/semigroups/files/semigroups-0.15.1-trust.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
commit 118b29f5404014d0a627767a4c7e8de4f00f9fce
Author: João Cristóvão <[email protected]>
Date: Wed Jul 23 12:27:29 2014 +0100

If GHC >= 7.8 module is always Thrustworthy, never safe, due to GHC.Exts

diff --git a/src/Data/List/NonEmpty.hs b/src/Data/List/NonEmpty.hs
index 8a28020..f3c2db5 100644
--- a/src/Data/List/NonEmpty.hs
+++ b/src/Data/List/NonEmpty.hs
@@ -1,7 +1,7 @@
{-# LANGUAGE CPP #-}

#if defined(__GLASGOW_HASKELL__) && __GLASGOW_HASKELL__ >= 702
-#ifdef MIN_VERSION_hashable
+#if defined(MIN_VERSION_hashable) || __GLASGOW_HASKELL__ >= 708
{-# LANGUAGE Trustworthy #-}
#else
{-# LANGUAGE Safe #-}
diff --git a/src/Data/Semigroup.hs b/src/Data/Semigroup.hs
index 7d41775..88fcbb0 100644
--- a/src/Data/Semigroup.hs
+++ b/src/Data/Semigroup.hs
@@ -8,7 +8,7 @@
#if defined(__GLASGOW_HASKELL__) && __GLASGOW_HASKELL__ >= 702
#define LANGUAGE_DefaultSignatures
{-# LANGUAGE DefaultSignatures #-}
-#ifdef MIN_VERSION_hashable
+#if defined(MIN_VERSION_hashable) || __GLASGOW_HASKELL__ >= 708
{-# LANGUAGE Trustworthy #-}
#else
{-# LANGUAGE Safe #-}
4 changes: 4 additions & 0 deletions dev-haskell/semigroups/semigroups-0.15.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"

src_prepare() {
epatch "${FILESDIR}"/${P}-trust.patch
}

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bytestring bytestring) \
Expand Down

0 comments on commit 61e7ac4

Please sign in to comment.